[Samba] Network and Reboot Problem

Eric Hines eehines at comcast.net
Sat Jan 14 16:35:22 GMT 2006


I'm running a Samba server (SUSE 9.3 and Samba 3.0.22pre1) on a 
2-subnet LAN, with a Win2k PC on one subnet and an XP laptop on the 
other.  When I boot up the server and then the two windows devices at 
the start of a day, everything comes up just fine, the server appears 
in Network Neighborhood and in Explorer, and I have access to my 
shares normally.

However, my problem is this: if I have occasion to reboot either (or 
both) Windows devices after having successfully formed the LAN, I 
can't get back to my shares except through some convoluted 
machinations, and the server no longer appears in NN or in 
Explorer.  When I run START|RUN|\\lserver0\ehines, I get access to 
the ehines home share.  When I run, from a DOS command line, net view 
\\lserver0, I get a listing of all the shares to which I'm supposed 
to have access.  Net use \\lserver0\<share> returns a successful 
completion message.  I get this behavior on both devices, and whether 
I cold reboot or log off one user and log on another.

This acts like a Windows thing, rather than a general network problem 
(although I really have no hard data or knowledge with which to 
substantiate that).  Do any of you have any ideas about how to pursue 
and correct this?


Eric Hines

There is no nonsense so errant that it cannot be made the creed of 
the vast majority by adequate governmental action.
         --Bertrand Russell

More information about the samba mailing list