[Fwd: Re: [Samba] -- SOLVED -- "valid users" + ldap on Solaris 10 problems]

Miki Monguilod Serena mikim at salleURL.edu
Thu Jan 12 19:33:28 GMT 2006

Hi All!

We have just solved the problem.
The error resides in the code placed in
/samba-X.X.X/source/lib/util_getent.c between line 275 and 291 . By
default, when you compile samba with solaris support, samba uses
"getgrnam" function because of the "BROKEN_GETRNAM=1" in Makefile. This
function is what's making samba going wrong. The soluction was to undefine
"BROKEN_GETRNAM" in order to make samba use " getgrent()" funtcion

Thanks for all your help guys!


> On Thu, 12 Jan 2006, Miki Monguilod wrote:
>> Hi Gerald,
>> We have Solaris 10 completely updated up today.
>> About samba and libraries, we have compiled Samba againt OpenLdap
>> (usr/local/lib/libldap.*) and of course, nss_ldap is linked against Sun
ldap's libraries /usr/lib/libldap.*) .
>> The big deal is why is Samba using Sun's ldap libraries instead of
>> one's when is getting any group entry.
>> Otherwise thanks for your reply. Have anybody got more ideas?
> I bet it works if you run nscd...  :)
>  	Andy
> --
> To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list