[Samba] samba, cups and cupsaddsmb

Adam Nielsen adam.nielsen at uq.edu.au
Thu Jan 5 01:27:23 GMT 2006

> I am used to do the following to install a new printer using the cups
> driver, (which is in /usr/share/cups/drivers - and also tried the
> same with adobe and wind. generic ps driver)

So if you type "ls /usr/share/cups/drivers" you get e.g. "ps5ui.dll"
and other driver files showing up?  All filenames are lowercase?

> 1. I install the printer in cups with its ppd file - from foomatic-db
> or vendor ppd over the webinterface (its the best way for me)
> 2. reload the smb.conf for the new printer be seen from samba
> 3. cupsaddsmb -U adminuser -v cupsprintername

You should probably do step #3 before #2, so that when Samba first
notices the printer the driver files are already available.

> step 3 should copy the files the windows clients need to
> printer-driver-path from smb.conf ([print$]) wich in this case
> is /var/lib/samba/printers here are is the folder W32X86 with the
> subfolders 2 and 3. The drivers are the copied to one of theese two.

What happens if you manually copy the files to the print$ share?  Does
it make a difference if you make the print$ share
world-writable/unrestricted when you run cupsaddsmb, just in case it's
a permissions problem?

> Now on my new installations (i tried many times in the last days) the
> drivers are not copied to the [print$] share, so the windows client
> don't find them.

You could try copying the generic Adobe drivers to print$/W32X86/3/
which is where my files are located.  This should be enough to get it
working with the Adobe driver - I'm not sure where the other drivers
put their files but if you could find this out you should be able to
use any driver.


More information about the samba mailing list