[Samba] samba, cups and cupsaddsmb

Angela Gavazzi edv at goetheanum.ch
Wed Jan 4 09:00:23 GMT 2006

I am used to do the following to install a new printer using the cups driver, 
(which is in /usr/share/cups/drivers - and also tried the same with adobe and 
wind. generic ps driver)

1. I install the printer in cups with its ppd file - from foomatic-db or 
vendor ppd over the webinterface (its the best way for me)
2. reload the smb.conf for the new printer be seen from samba
3. cupsaddsmb -U adminuser -v cupsprintername

step 3 should copy the files the windows clients need to printer-driver-path 
from smb.conf ([print$]) wich in this case is /var/lib/samba/printers
here are is the folder W32X86 with the subfolders 2 and 3. The drivers are the 
copied to one of theese two.
from here the windows clients get the driver when "connecting" to the printer 
the first time.

Now on my new installations (i tried many times in the last days) the drivers 
are not copied to the [print$] share, so the windows client don't find them.

so it looks like the driver was "cupsadded" but it isn't really.
This is the problem and I really don't find out what i could have forgotten to 
configure or to do.

thanks for answer!

cheers angela

Am Mittwoch, 4. Januar 2006 04.39 schrieben Sie:
> > I installed a new samba-cups server on a sarge machine. Windbind
> > works, I can get all users and groups.
> > I copied the generic windows postscript driver files as in
> > cupsaddsmb-manpage described to /usr/share/cups/drivers (tried also
> > adobe drivers) Also tried the same with the cups driver, that I would
> > prefere to use. Installed a printer in cups (test), reloaded smb.conf
> > (also restarted samba) - I can see the printer from windows.
> What precisely is the problem?  This seems like a fine setup.
> > When I try to cupsaddsmb the printer driver for the windows clients,
> > nothing happens. No driver is copied
> > to /var/lib/samba/printers/W32X86/3, on the console I get the
> > message, that the driver was addedd successfully, nothing seem to be
> > written to printers.tdb (size doesn't change and tdbbackup gives an
> > empy file)
> AFAIK, cupsaddsmb only tells Samba there's a new CUPS printer it should
> make available over the network.  It doesn't have anything to do with
> drivers, that's a CUPS issue.  cupsaddsmb will "install" standard
> PostScript drivers if you have them, as that's what CUPS uses to
> print.  If you want to use the native Windows drivers for your printer,
> you'll presumably have to install the files manually.  I'm not sure
> where to start with this, as I've only ever used the Adobe PS driver.
> Cheers,
> Adam.

More information about the samba mailing list