[Samba] samba, cups and cupsaddsmb

Adam Nielsen adam.nielsen at uq.edu.au
Wed Jan 4 03:39:15 GMT 2006

> I installed a new samba-cups server on a sarge machine. Windbind
> works, I can get all users and groups.
> I copied the generic windows postscript driver files as in
> cupsaddsmb-manpage described to /usr/share/cups/drivers (tried also
> adobe drivers) Also tried the same with the cups driver, that I would
> prefere to use. Installed a printer in cups (test), reloaded smb.conf
> (also restarted samba) - I can see the printer from windows.

What precisely is the problem?  This seems like a fine setup.

> When I try to cupsaddsmb the printer driver for the windows clients,
> nothing happens. No driver is copied
> to /var/lib/samba/printers/W32X86/3, on the console I get the
> message, that the driver was addedd successfully, nothing seem to be
> written to printers.tdb (size doesn't change and tdbbackup gives an
> empy file)

AFAIK, cupsaddsmb only tells Samba there's a new CUPS printer it should
make available over the network.  It doesn't have anything to do with
drivers, that's a CUPS issue.  cupsaddsmb will "install" standard
PostScript drivers if you have them, as that's what CUPS uses to
print.  If you want to use the native Windows drivers for your printer,
you'll presumably have to install the files manually.  I'm not sure
where to start with this, as I've only ever used the Adobe PS driver.


More information about the samba mailing list