[Samba] maximum password age

Francesc Guasch frankie at etsetb.upc.edu
Mon Jan 2 19:12:37 GMT 2006

En/na nik600 ha escrit:
> On 12/23/05, Alessandro <ml at arrangiarsi.com> wrote:
>>  # pdbedit -P "maximum password age" -C 1003089564
>>  # smbpasswd storm
>>  New SMB password:
>>  Retype new SMB password:
>>  # pdbedit -v -u storm | grep must
>>  Password must change: mar, 06 ott 2037 18:38:54 GMT

>>hmm... i've tried to change the password from the windows client, not with

> the smbpasswd utility, maybe the problem is this!

Hi. I too have been dealing lately with this issue. It started
working, but when I messed wit the settingsit stopped working.
Today I gave it another random try and it worked again, when
I mess with it again, the date didn't change anymore.

When I try it the very first time I changed the backend to tdbsam
it worked fine untill I started changing passwords and ages.
I got stuck and I was unable to change the policy, even following
the exact commands as Alessandro wrote.

Anyway, today I gave it another try and surprisingly it worked.
I configured:
   "maximum password age" -C 1003089564

Then it didn't show the 1901 date:

    Password must change: Fri, 16 Oct 2037 16:44:01 GMT.

Then I set it to 24 hrs ( 86400 ), I change the password with
smbpasswd, so I see:

    Password must change: Tue, 03 Jan 2006 19:47:37 GMT

Then I try to set it to a different number, no matter what I
try it won't change.

Tomorrow I expect it asks me to change my password, I wish then
I set it to another number and see what happens.

My feeling is there is something slightly broken there. But maybe
if you just set an expiration age and don't mess with it, it just
works. About using smbpasswd or windows, I think it's not important
I made it work changing from windows once, though I try it more
with smbpasswd because it's easier to type.

More information about the samba mailing list