[Samba] Access Denied Error On Windows XP --> Linux Printer

Hal Vaughan hal at thresholddigital.com
Sun Jan 1 05:39:22 GMT 2006

I'm running Samba Version 3.0.14a on Debian Linux.  My sm.conf is listed at 
the end of this message.  I have two printers on server.thresh.lan, a Brother 
HL-1440 laser printer and an HP-5510 Office Jet 
(printer/scanner/fax/copier/gopher and dishwasher).  The Brother is named 
"laser" and the HP is named "multiuse".  I have a multi-boot system on the 
LAN that can boot Windows 98, Windows 2000, and Windows XP.  Right now I'm 
working with Windows XP.  I had no problem installing the Brother printer on 
Windows XP.  There was no problem with the printer being a network printer.

I have tried to install the HP printer.  I couldn't find the original driver 
disk, so I downloaded the drivers from HP.  Part way through the install, the 
HP program tells me to connect the USB cable to the computer.  Of course I 
can't do that, since the printer is connected to my server.  I tried 
installing from the "Add Printers" program in the "Printers" window, and 
searched to see if there were a .inf file in the unpacked files from the HP 
install, but could not find one that "described my printer" (as Windows puts 
it).  I finally installed it with the HP Office Jet driver listed by Windows 
as one of the pre-installed drivers.

It installed, but there is no apparent connection.  When I right click on the 
icon for this printer and select "Open", I get the printer queue listing 
window with the message "Access denied, unable to connect" in the titlebar.  
There are no error messages or any corresponding messages in my Samba logs.

After searching, I found one thing I tried.  I opened the command prompt and 
typed in "echo Hello >//server/multiuse" and it printed on the HP printer.  
This leads me to believe the problem is in the Windows drivers, since it is 
clear the systems connect and another shared printer is accessible.  It's 
also clear Samba is listening and receiving messages sent to this printer.

The HP Office Jet driver was the closest driver in Windows that I could see to 
try to match to the Office Jet 5510.  I could not get any driver package from 
HP to work because they don't want to work with the printer on another 

If anyone knows what I can do to get this printer working, please let me know.  
I need it for testing a project I'm working on for a client.  My guess is I 
need a driver that doesn't mind if it's on the network, but I'm open to 
whatever is practical and makes this printer work.



        workgroup = THRESH.LAN
        netbios name = SERVER
        server string = Samba Server %v
        encrypt passwords = Yes
        log file = /var/log/samba/log.%m
        max log size = 1000
#       socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        printcap name = cups
        wins support = Yes
        printer admin = root hal
        create mask = 0777
        directory mask = 0777
        printing = cups

        comment = All Printers
        path = /var/spool/samba
        printer admin = hal root
        create mask = 0700
        guest ok = Yes
        printable = Yes
        print command = /usr/bin/lp -P %p -oraw -r %s
        browseable = No

        comment = Storage and extra program space for Windows test systems
        path = /data/Data/WinStuff
        read only = No

        path = /data/Data/Audio
        read only = Yes

More information about the samba mailing list