[Samba] Problem with large files corrupting during transfer

James Watkins misterwatto at gmail.com
Fri Aug 25 08:20:02 GMT 2006

Ramsey Wes - wramse wrote:
> Files >2.8gb are corrupting during the transfer. That 2.8gb file is the
> largest we've gotten to go through successfully. The next largest file
> is 5.7gb, and corrupts without fail. The 1st section of the file looks
> normal, the next large chunk is corrupt, and the remainder of the file
> is simply binary trash. It looks to me like 2(+) users are accessing the
> file while it is writing to cache, which would explain this, but I have
> no way to prove it. I tried adding 'oplocks = no' and 'strict locking =
> yes', but neither fixed the problem. If more info is needed, please let
> me know.

Hi, I'm afraid I can't help you but I can tell you that I had a similar 
problem that I gave up on some time ago.  I found that windows 2k could 
transfer the files perfectly well to my samba box so I guess it must be 
an NT problem.  I posted this to the list:


and only received one reply:


Having verified that I was running SP6, I lost interest and tried to 
persuade my boss to fund an upgrade to our windows servers instead.  I'm 
assured that the upgrade will happen some time this year :-) but I'd 
still be very interested to hear from you if you manage to fix the problem.

Good luck,


More information about the samba mailing list