[Samba] Browsing problem

Niki Hammler smb94532543 at stiftingtal.net
Tue Apr 11 01:12:14 GMT 2006


I've got a browsing problem, I'm searching the error for a long time now 
so I think betimes it's a bug ;-)

For debugging purposes, I've left away everything in the network that's 
not necessary. There's now only one XP-Prof workstation (domain member) 
and one samba server (3.0.22, acting as PDC) anymore.

Bind9 is the local DNS server; Forward and PTR entries are working. The 
DNS domain is the same as the NT.

The problem is: Everything works (domain logons, searching the computer 
with the windows search feature, accessing with \\server, ...) EXCEPT 
the network neighbourhood. It is empty and there is no PC in it. There 
is no error and there is no delay while searching.

Here is a copy of my smb.conf:

         netbios name = server
         workgroup = INTRA.COMPANY.NET
         server string = server
         passdb backend = tdbsam

         os level = 128
         preferred master = yes
         domain master = yes
         local master = yes

         security = user
         encrypt passwords = true
         domain logons = yes
         logon path = \\%L\profile
         logon drive = U:
         logon home = \\%N\%U
         logon script = logon.cmd

         map to guest = never
         ;guest account = nobody
         ;map to guest = Bad User
         ;username map = /etc/samba/users.map
         unix password sync = yes
         passwd program = /usr/bin/passwd %u
         passwd chat = Enter*new*UNIX*password: %n\n 
\nRetype*new*UNIX*password: %n\n \npasswd:*password*updated*successfully*

         ;time server = yes
         wins support = yes
         ;dns proxy = yes
         name resolve order = lmhosts wins bcast host

         printing = cups
         printcap name = cups
         load printers = yes

         preserve case = yes
         dos charset = CP850
         create mask = 600
         directory mask = 700
         short preserve case = yes
         unix charset = ISO8859-1

         log level = 3
         ; log file = /var/log/samba/smb%m.log
         log file = /var/log/samba/SMB.log
         max log size = 50000


As you can see, I've configured samba as WINS-server.
Clients configuration is assigned by DHCP with:

option netbios-node-type 8;
option netbios-name-servers;

I've tried almost everything I could but I'm unable to find the error. 
The first strange thing is (on the server itself):

$ smbclient -L server -U %
Domain=[INTRA.COMPANY.NET] OS=[Unix] Server=[Samba 3.0.22]

         Sharename       Type      Comment
         ---------       ----      -------
         web-publish     Printer   publish PDF on homepage
         pub             Disk      public place
         IPC$            IPC       IPC Service (server Server)
         ADMIN$          IPC       IPC Service (server Server)
Domain=[INTRA.COMPANY.NET] OS=[Unix] Server=[Samba 3.0.22]

         Server               Comment
         ---------            -------

         Workgroup            Master
         ---------            -------

As you can see, there is NO (!) server or workgroup although WINS, DNS 
etc etc is properly configured.

On windows:

no entries in list

Knoten-IP-Adresse: [] Bereichskennung: []


         Name              Typ        Hostadresse     Dauer [Sek.]

Knoten-IP-Adresse: [] Bereichskennung: []

                 Lokale NetBIOS-Namentabelle

        Name               Typ          Status
     STYLISTIC         <00>  EINDEUTIG   Registriert
     INTRA.COMPANY.NET <00>  GRUPPE      Registriert
     STYLISTIC         <20>  EINDEUTIG   Registriert
     INTRA.COMPANY.NET <1E>  GRUPPE      Registriert

Knoten-IP-Adresse: [] Bereichskennung: []

       NetBIOS-Namentabelle des Remotecomputers

        Name               Typ          Status
     SERVER           <00>  EINDEUTIG   Registriert
     SERVER           <03>  EINDEUTIG   Registriert
     SERVER           <20>  EINDEUTIG   Registriert
     ..__MSBROWSE__.  <01>  GRUPPE      Registriert
     INTRA.COMPANY.NET<00>  GRUPPE      Registriert
     INTRA.COMPANY.NET<1C>  GRUPPE      Registriert
     INTRA.COMPANY.NET<1E>  GRUPPE      Registriert

     MAC Adresse = 00-00-00-00-00-00

Status for domain INTRA.COMPANY.NET on transport 
     Browsing is active on domain.
     Master browser name is: SERVER
         Unable to determine build of browser master: 2
     \\\\SERVER         .  Version:04.09  Flags: 9a0b NT CONTROLLER SERVER
     1 backup servers retrieved from master SERVER
     There are 0 servers in domain INTRA.COMPANY.NET on transport 
     There are 0 domains in domain INTRA.COMPANY.NET on transport 

As you can see, "0 servers" and "0 domains" in domain. This can't be 

In the log files, there is really nothing that looks like an error 
message, but if you want to have logs, I really like to send them.

I even tried to analyze traffic with Ethereal, there were lots of 
NetServerEnum2 Requests for domain INTRA.COMPANY.NET but in the 
responses there was always a "Entry count:0" and "Available entries: 0".

Can you help me?
Or is this really a bug?

Thank you very much!

Best Regards,

   desperate Niki

More information about the samba mailing list