[Samba] 3.0.21c and big wmv or mpg files

Tom Peters tpeters at mixcom.com
Sat Apr 1 01:02:22 GMT 2006

At 10:40 PM 3/29/2006 +0200, you wrote:
>Hi @all,
>are there any problems known with 3.0.21c and bigger video files (mpg and 
>wmv greater than 700 MB)?
>Received the information that these files cannot copied from XP to Samba 
>(W2K is okay). Error message is the well known:
>[2006/03/28 18:03:36, 0] lib/util_sock.c:get_peer_addr(1225)getpeername 
>failed. Error was Transport endpoint is not connected

I chased this elusive problem for a year. I'm still running 3.09-2.3 but I 
see it on other versions.

Tell me, do you get this problem when you drag/n/drop a file into a folder 
on the samba share? And can you prevent this problem from occurring by the 
following procedure?

Click in the target window on the samba machine (this is on the XP 
desktop). Press F5 to refresh the view. Wait about a second. Immediately 
start your copy. When I do this, the errors, previously reported to the 
desktop and to my server log, don't occur.

I've been told that it's a WinXP only issue, that it attempts to connect on 
ports 445 and 139 nearly simultaneously, and then proceeds to talk over 
whichever one answers first. I'm told that Win2k clients won't have this 
problem, and Win98 clients don't use port 445 so it doesn't arise there.

Anyone have evidence to the contrary (so far)?

My thinking is that WinXP improperly responds to an attempt to open a 
conversation on a different port than the one Samba expects. Maybe the TCP 
stack on SuSE is more rigorous and respects the sequence numbers and 
considers a connection... ...a connection. Dunno.  Need to get busy with 
Ethereal maybe.

First thing I tried: In smb.com, add a line reading
smb ports = 139
which I hoped would tell it just don't reply on port 445 at all. This did 
not help.

Next thing I tried, rather a kludge,
iptables -I INPUT 1 -p tcp --dport 445 -j DROP

Hey guess what? I haven't had a single incidence of the error since.

My explanation, as near as I can figure out, of what the rule does:

iptables        ; firewall / packet filter
  -I INPUT 1     ; Insert into chain "INPUT" as rule #1
-p tcp --dport 445      ; a rule for packets whose protocol is tcp AND 
destination port is 445
  -j DROP        ; if matches rule, Jump to target "DROP"

The predefined target DROP is not another chain but actually means throw 
the packet away.
I'm allowing port 139 through (by default) instead of 445 because I still 
have the odd Win98 machine laying about.

That's my story, and I'm sticking to it.


[Commentary] Despite of the cost of living, it remains popular.
--... ...--  -.. .  -. ----. --.- --.- -...
tpeters at nospam.mixcom.com   (remove "nospam") N9QQB (amateur radio)
"HEY YOU" (loud shouting)  WEB ADDRESS http//www.mixweb.com/tpeters
43° 7' 17.2" N by 88° 6' 28.9" W,  Elevation 815',  Grid Square EN53wc
WAN/LAN/Telcom Analyst, Tech Writer, MCP, CCNA, Registered Linux User 385531

More information about the samba mailing list