[Samba] Samba transfer problems

Jochen Schurich Test jochen at test.schurich.com
Tue Sep 20 18:51:23 GMT 2005

hi all!

i have a very strange problem with samba:
when i try to copy some files with samba the connection freeze and after 
some time i get can read in my log file:
Sep 16 22:47:35 srv01 smb_add_request: request [dd6d1e40, mid=29034] 
timed out!
Sep 16 22:48:36 srv01 smb_add_request: request [dd6d1e40, mid=34953] 
timed out!
Sep 16 22:49:06 srv01 smb_add_request: request [dd6d1e40, mid=34954] 
timed out!
Sep 16 22:49:36 srv01 smb_add_request: request [dd6d1e40, mid=34955] 
timed out!
Sep 16 22:49:36 srv01 SMB connection re-established (-5)

what i allready did:
i tried the masked samb version samba-3.0.20-r1
i tried these parameter in my smb.conf:
use sendfile = no
large readwrite = no
max xmit = 16644
i tried to mount my NT4 share with cifs but i only get:
mount error 111 = Connection refused
i upgraded my kernel to the latest gentoo-sources 2.6.13-r1
i changed my network card from forcedeth to a 8139too card

now i downgraded my kernel to 2.6.9-gentoo-r9 but the problem is the same.

i installed samba 3.0.6-r4 and no luck (i tried many different kernels)
btw.: the same kernel and samba version is working on different hardware 
without problems.
i'm using a router (with openwrt.org linux installed) which is working 
fine and i can transfer many, many gigs wich many other protocols (ftp, 
scp, http).

could it be the router? but i don't know how to find out what exactly 
causes this problem.

i sniffed the communication on the router and got "checksum incorrect".

does anyone know how to solve this problem?
and now i have no idea what to do next :-(


More information about the samba mailing list