[Samba] Samba 3 Unable to join domain

Daulton Theodore daulton at library.carleton.ca
Tue Sep 20 19:30:36 GMT 2005

I am currently running Samba 2.2.8a in a production environment on a Unix 
box with Solaris 8. I am hoping to migrate and upgrade to Samba 3.0.10 on a 
Solaris 10 box. I am however having difficulties joining the NT domain with 
my new (still test server).

Initially I provided the administrator with the ip address and the netbios 
name of the samba server so that a trust account could be created. After 
having no success joining I had the old account deleted and a new account 
created with the same ip address and the Unix hostname (different from the 
netbios name). Still no success. Here is the result of my join and oldjoin 

# net rpc join MEMBER -S PDC_name

# net rpc oldjoin MEMBER -S PDC_name
Failed to join domain

Joining the domain was painless with the smbpasswd command for version 2.2.8. 
According to all that I.ve read (maybe not enough) it should also be easy 
with version 3x with the join/oldjoin command. The account exists but I 
still get prompted for a password when using the join command. I do not have 
the admin password and I think this should be do-able without providing the 

Has anyone else encountered this problem? Any suggestions on how to get 
past this?

Here is a section of my smb-conf file
# Global parameters
   netbios name  = horntail
   server string = Library's %L %v
   workgroup     = CARLETON.CA
   local master  = no
   allow hosts   = 134.x.x. 134.y.y
   security      = domain
   browsable     = yes

   password server = server1.nt server2.nt server3
   machine password timeout = 314496000
   remote announce = 134.x.x.x
   wins server = winsservername

#  force Samba to bind only to hme0
   interfaces    = 134.x.x.x/
   bind interfaces only = yes
   socket options = SO_KEEPALIVE TCP_NODELAY
   deadtime     = 0

#  Encrypt all passwords stored in /usr/local/samba.private/smbpasswd
   encrypt passwords = yes
   username map = /usr/local/samba/lib/nt-names
   smb passwd file   = /usr/local/samba/private/smbpasswd

   writeable     = yes

#  Debug Logging information
   log level = 2
   log file = /usr/local/samba/var/log.%m

Any suggestions would be much appreciated.
----------------------------------- 0 ------------------------------------
Daulton Theodore                  </\    Tel: 613-520-2600 ext. 8352
Carleton University Library       _\\    Fax: 613-520-2750            
Systems Department                `/     Net: Daulton_Theodore at carleton.ca
---------------------------------- ` -------------------------------------

More information about the samba mailing list