[Samba] Samba closing printer prematurely?

Paul Griffith paulg at cs.yorku.ca
Tue Sep 20 19:09:19 GMT 2005

Greetings Samba Users,

I have a strange issue. Adobe Reader can't print to a Samba
printer. It would be funny except it is happening to me....

Adobe Reader can't print PDF files to a true Adobe PS3 printer but GhostView can
print PDF files without any problems.

The printer in question is a Ricoh Aficio AP4510.

I tried Samba v3.0.11 and v3.0.20 and I get the same result, no
printer output.

As a member of the Domain Admin group I can print from AcroReader
without any problems. All other users can't print....sounds like a
permission problem.
Using FileMon from SysInternal I see spoolsv.exe returning a ACCESS
DENIED error. A ethereal dump shows communications between the client and the
Samba Server.

A level 4 debug level from Samba shows:

[2005/09/20 14:31:16, 3] smbd/reply.c:reply_printopen(3535)
  openprint fd=5 fnum=9756
[2005/09/20 14:31:16, 3] smbd/process.c:process_smb(1114)
  Transaction 566 of length 41
[2005/09/20 14:31:16, 3] smbd/process.c:switch_message(900)
  switch message SMBsplclose (pid 758) conn 0x8311a10
[2005/09/20 14:31:16, 4] smbd/uid.c:change_to_user(217)
  change_to_user: Skipping user change - already user
[2005/09/20 14:31:16, 3] smbd/reply.c:reply_printclose(3561)
  printclose fd=5 fnum=9756

Seem like Samba is opening and closing the printer connection at the
same timem, so nothing is getting down the pipe.

Anyone have any tips, ideas I can try?

As I said this problem is only with AcroReader v7.0.3 on a fully patched
WinXP2 box.


More information about the samba mailing list