[Samba] stale name lookup result

Brandon Kuczenski brandon at 301south.net
Mon Sep 19 17:50:07 GMT 2005

I am running a Samba 3.0.10 server on freeBSD and 3.0.10-Debian client.  I 
just had a perplexing problem.

The client is a laptop and moves about different samba networks.  My home 
computer's name (Unix hostname and samba name) is 'ocean'.  When I'm at 
home I run smbmount //ocean/mydir /mnt/samba/ocean/mydir -o <options>

Normally this is fine.  I've been running the same script to do this for 
about 2 years, without problems.

But this morning when I tried to connect it kept telling me
timeout connecting to NOT.MY.IP.ADDR:445
timeout connecting to NOT.MY.IP.ADDR:139

[NOT.MY.IP.ADDR is replaced by an actual IP address that I've never seen 
before, but belongs to a separate wireless network that I occasionally 

Running nmblookup:
# nmblookup ocean
querying ocean on         <-- this IS my network ocean<00>			<-- this IS the right IP address

Ocean is right there in the next room -- AND it's acting as a WINS server 
-- AND nmblookup seems to find it just fine.  Why is my laptop trying to 
connect to the wrong host?

Thanks in advance,

More information about the samba mailing list