[Samba] Problems installing printer driver

Martin Zielinski mz at seh.de
Tue Sep 13 07:19:36 GMT 2005


The driver works on my installation.
But I remember a case where a driver package contained read-only files. 
They have been created on the samba server but could never be removed 
('cause they were read only;-)

The PPD-Files (the driver only contains ppd-files) of this package _are_
read-only (Properties -> Attributes -> Write Protected). You might try 
to remove this flag on (should be) KM6020EG.PPD and repeat the 

It seems, that samba creates  a temporary read-only file (SET12.tmp) and
fails to reopen it to move it or change some other properties.

Just an idea!


Wolf Wiegand wrote:
> Hello,
> (please excuse poor translations of german Windows-GUI-items)
> a customer of ours has a strange problem trying to install a printer
> driver on the print$ share. The driver in question comes from
> http://www.kyocera.de/kyocera_n/german/downloads/downloads.html ->
> choose 'Treiber' -> choose 'Produkt Typ: Drucker', choose 'Produkt:
> FS-6020', choose 'Sprache: Deutsch' -> 'Mini-KPDL-Win2K_XP-v8.2-DE.exe'
> (the 9th item of the top). This is a multi driver package, the driver in
> question is the one for a Kyocera FS-1118MFP(KPDL).
> The printer driver is installed on an XP Pro machine, the user has
> authenticated against samba as a person from the printer admin group.
> The user opens explorer -> Network Neighbourhood -> samba server ->
> printers and fax machines. In the file menu, he choses server
> properties -> drivers -> add and tries to add the above mentioned
> driver. Some files are then being copied to the samba server, but then
> copying stops with a message "Access Denied".
> The (reproducible) problem is a file which is tried to be copied to
> W32X86/:
> [2005/09/07 13:12:28, 5] smbd/open.c:open_file_shared1(1148)
>   open_file_shared: read/write access requested for file
> W32X86/SET12.tmp on read only file
> [2005/09/07 13:12:28, 5] smbd/files.c:file_free(439)
>   freed files structure 9190 (0 used)
> [2005/09/07 13:12:28, 10] smbd/trans2.c:set_bad_path_error(2191)
>   set_bad_path_error: err = 13 bad_path = 0
> [2005/09/07 13:12:28, 3] smbd/error.c:error_packet(105)
>   error string = Permission denied
> [2005/09/07 13:12:28, 3] smbd/error.c:error_packet(129)
>   error packet at smbd/trans2.c(2200) cmd=162 (SMBntcreateX)
> We've tried copying a file to that location using smbclient, which
> worked. Other printer drivers are no problem, either. And, strangly
> enough, this does not seem to be a problem with 3.0.7, but with both
> some older and newer versions (including .20).
> The printer$ section in smb.conf looks like this:
> [print$]
>         comment = Printer Drivers
>         path = /var/lib/samba/drivers
>         write list = root, Administrator, at Printer-Admins
>         read only = No
> Anybody has an idea what the problem may be?
> Regards,
> Wolf

Martin Zielinski             mz at seh.de
Software Development
SEH Computertechnik GmbH     www.seh.de

More information about the samba mailing list