[Samba] RE: [SLE] SuSE 9.3 and Latest Binaries - Library Conflict

Marlier, Ian Ian.Marlier at studentuniverse.com
Mon Sep 12 22:44:20 GMT 2005

Cross-posting scares me, but...

Have you looked at the latest RPMs for SuSE, from ftp://ftp.suse.com/pub/projects/samba/ ?

They've worked like a charm for me, thus far (revision after revision, a simple rpm -U * seems to work...)

-----Original Message-----
From: david rankin [mailto:drankin at cox-internet.com]
Sent: Mon 9/12/2005 5:30 PM
To: samba; Suse Linux
Subject: [SLE] SuSE 9.3 and Latest Binaries - Library Conflict

    Still can't get the latest samba binaries to inatall on SuSE 9.3.  I've 
downloaded them from the samba site and from 
ftp://ftp.primastasys.com/pub/Samba-Packages/ still no joy. The problem is 
library related:

nemesis:/home/david/Documents/linux/rpms/samba320 # rpm -Uvh *
warning: cifs-mount-3.0.20-0.1.i586.rpm: V3 DSA signature: NOKEY, key ID
error: Failed dependencies:
        perl-ldap is needed by ldapsmb-1.33-3
        liblber.so.2 is needed by libsmbclient3-3.0.20-1
        libldap.so.2 is needed by libsmbclient3-3.0.20-1
        liblber.so.2 is needed by samba3-3.0.20-1
        libldap.so.2 is needed by samba3-3.0.20-1
        liblber.so.2 is needed by samba3-client-3.0.20-1
        libldap.so.2 is needed by samba3-client-3.0.20-1
        libreadline.so.4 is needed by samba3-client-3.0.20-1
        libmysqlclient.so.12 is needed by samba3-pdb-3.0.20-1
        python < 2.3.99 is needed by samba3-python-3.0.20-1
        liblber.so.2 is needed by samba3-python-3.0.20-1
        libldap.so.2 is needed by samba3-python-3.0.20-1
        liblber.so.2 is needed by samba3-winbind-3.0.20-1
        libldap.so.2 is needed by samba3-winbind-3.0.20-1

Now in SuSE 9.3, the installed libraries are:

david at nemesis:~/Documents/linux/rpms/samba320> ls /usr/lib/libl*
/usr/lib/liblber-2.2.so.7       /usr/lib/libldapcpp.so.0
/usr/lib/liblirc_client.so        /usr/lib/libltdl.so.3
/usr/lib/liblber-2.2.so.7.0.16  /usr/lib/libldapcpp.so.0.0.3
/usr/lib/liblirc_client.so.0      /usr/lib/libltdl.so.3.1.1
/usr/lib/liblcms.so.1           /usr/lib/libldap_r-2.2.so.7
/usr/lib/liblirc_client.so.0.0.0  /usr/lib/liblwres.so.1
/usr/lib/liblcms.so.1.0.14      /usr/lib/libldap_r-2.2.so.7.0.16
/usr/lib/libltdl.a                /usr/lib/liblwres.so.1.2.2
/usr/lib/libldap-2.2.so.7       /usr/lib/liblirc_client.a
/usr/lib/libldap-2.2.so.7.0.16  /usr/lib/liblirc_client.la

I've contacted Lars about this.

Anybody got the binaries to work with 9.3??? Any other thoughts???

David C. Rankin, J.D., P.E.
510 Ochiltree Street
Nacogdoches, Texas 75961
(936) 715-9333
(936) 715-9339 fax

Check the headers for your unsubscription address
For additional commands send e-mail to suse-linux-e-help at suse.com
Also check the archives at http://lists.suse.com
Please read the FAQs: suse-linux-e-faq at suse.com

More information about the samba mailing list