[Samba] Help - Serious samba problem with Excel

Jamie Heckford jamie at tridentmicrosystems.co.uk
Mon Sep 5 18:49:10 GMT 2005


Damn I hate upgrades. After updating at the weekend to FreeBSD 5.4-R in 
a fresh install our samba server just doesn't want to play ball.

I have managed to get Samba3 working ok apart from when it comes to 
using Excel documents. If a user has an excel document open and another 
user tries to open it, Excel 2003 will fail with 'Unable to open the 
file, it may be read-only or encrypted'

It worked perfectly before, I have driven myself mad trying to get it to 
work all day :(

If anyone could lend a hand it would be very much appreciated...... 
relevant config, details etc. below:


FreeBSD 5.4-RELEASE-p6 #1: Sun Sep  4 16:37:13 BST 2005

samba-3.0.12_1,1 from FreeBSD ports (I have tried 3.0.20 as well, no luck)

         workgroup = TRIDENT
         server string = SERV01
         security = domain
         socket options = TCP_NODELAY
         netbios name = SERV01
         log file = /var/log/samba/log.%m
         dns proxy = no
         wins support = no
         interfaces =
         encrypt passwords = yes
         enhanced browsing = yes

          comment = Operations - Stats Area
          path = /u/stats
          force user = root
          guest ok = no
          writeable = yes
          valid users = user1, user2, user3, user4, user5

I have taken everything else out to try and solve this problem.

/u is mounted from another FreeBSD 5 box over NFS, I have tried all the 
various oplock settings as well and this didn't make any difference.


Jamie Heckford
Network Manager
Trident Microsystems Ltd.

t: +44(0)1737-780790
f: +44(0)1737-771908
w: http://www.trident-uk.co.uk/

More information about the samba mailing list