[Samba] Add Printer Wizard problem

Ong, Loeng Seng loeng.ong at vicscouts.asn.au
Mon Sep 5 00:54:34 GMT 2005

I really need help.

I tried to create a CUPS server but always failed to install Windows 
driver on the Server from Windows client using Add Printer Wizard.
The error message from the Windows client is: "Unable to install HP 
Laserjet 4050, Windows 2000, Intel server. Operation could not be completed"
Currently I set the printer installed on CUPS server as a local printer, 
eventhough it is a network printer. I will change it once I get this 
works. I have also create directory /etc/samba/drivers.

Error log message on var/log/samba:
  05it13 ( couldn't find service 
[2005/09/02 19:36:19, 1] smbd/service.c:make_connection_snum(648)
  05it13 ( connect to service print$ initially as user 
VICSCOUT\admin (uid=10553, gid=10000) (pid 12732)
[2005/09/02 19:36:49, 0] smbd/connection.c:register_message_flags(220)
  register_message_flags: tdb_fetch failed
[2005/09/02 19:36:49, 0] smbd/connection.c:register_message_flags(220)
  register_message_flags: tdb_fetch failed

   workgroup = VICSCOUT
        netbios name= 05IT20
        server string = Samba Server
        log file = /var/log/samba/%m.log
        max log size = 50
        preferred master = No
        local master = No
        domain master = No
        dns proxy = No
       load printers = yes
       printcap name = cups
       printer admin = root, admin, @Administrators
       printing = cups
       use client driver = yes

        comment = Home Directories
        read only = No
        browseable = No

        comment = All Printers
        path = /var/spool/samba
        printable = Yes
        browseable = No
        guest ok = yes
        public = yes
        writable = no

    comment = Printer Drivers
    browseable = Yes
    guest ok = no
    readonly = yes
    path = /etc/samba/drivers
    write list = root, admin, @Administrators

Previously, I tried to use cupsaddsmb -U root -v -a using "use client 
driver=no" and it gives me output :
Running command: rpcclient localhost -N -U'root%secret' -c 'setdriver 
RawQueue RawQueue'
params.c:Parameter() - Ignoring badly formed line in configuration file: 
Samba config file created using SWAT
Succesfully set RawQueue to driver RawQueue.

Best Regards,
Ong, Loeng Seng
Extranet Service Delivery Team
Scouts Australia Victorian Branch

Phone : 03 8543 9817
Facsimile : 03 8543 9840
E-mail : loeng.ong at vicscouts.asn.au
Website : www.vicscouts.asn.au/supportteam/#loeng

The Extranet Service Delivery Team consists of volunteer IT students and Team Leaders who appreciate the opportunity to learn and are delighted to provide you with seven days a week service.

*** This email (including all attachments) contains confidential information, which may be privileged. It is intended solely for the identified recipient(s) to whom it is addressed. If you are not an intended recipient, please notify Scouts Extranet Service Team immediately and delete this message from your system. Please note that any views or opinions presented in this email are solely those of the author and do not necessarily represent those of the company. You may not copy or use it for any purpose, or otherwise disclose its contents to any person. ***

More information about the samba mailing list