[Samba] USRMGR.EXE doesn't work anymore.

Bruno Guerreiro bruno.guerreiro at ine.pt
Fri Sep 2 11:25:37 GMT 2005

After applying the patches available today, all the problems i've mentioned
have disappeared.

Testing an older one, it still exists.
If I add a user to more than 60 or 70 groups, that usermanager can no longer
manage that user. It gives: 

"The remote procedure call failed
The user properties cannot be edited or viewed at this time"

I then have to refresh user/group list or else every user will fail
That user also can't access resources which permissions are group based.
In the samba log's the following lines appear:

*** glibc detected *** double free or corruption (!prev): 0xb879cc10 ***

Best Regards,
Bruno Guerreiro

>-----Original Message-----
>From: Gerald (Jerry) Carter [mailto:jerry at samba.org]
>Sent: quinta-feira, 1 de Setembro de 2005 20:10
>To: Umberto Zanatta
>Cc: Bruno Guerreiro; gasch at eva.mpg.de; 'samba at lists.samba.org'
>Subject: Re: [Samba] USRMGR.EXE doesn't work anymore.
>Hash: SHA1
>Umberto Zanatta wrote:
>| Hi,
>| my test system is a w2k server. my server is a SLES8 with 
>Samba 3.0.20
>| (I get it from ftp.sernet.de).
>| I've tried to start srvmgr: same result!
>| it says: «Il servizio Server non è avviato» - I can 
>translate in: «The
>| service Server is not start».
>| There are some strange randoms errors on smbd (but not when usrmgr e
>| srvmgr starts):
>| Sep  1 20:44:41 provtvlp smbd[7699]:   Failed to setup 
>| handler
>| Sep  1 20:44:41 provtvlp smbd[7699]: [2005/09/01 20:44:41, 0,
>| effective(0, 0), real(0, 0)]
>| smbd/notify_kernel.c:kernel_notify_init(224)
>| On other way samba is working better than old one.
>So I'm confused.  What is not working in 3.0.20 after
>applying the patches at http://www.samba.org/samba/patches/ ?
>cheers, jerry
>Version: GnuPG v1.4.0 (GNU/Linux)
>Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

More information about the samba mailing list