Re-2: [Samba]SOLVED - idmap_rid / roaming profile permissions /NTAUTHORITY\SYSTEM

Stefanos Karasavvidis sk at
Thu Sep 1 09:52:29 GMT 2005

because the same samba fileserver will also have the home directories 
for linux users!

According to the smb.conf man pages, the value auto will corretcly apply 
case insensitivity for windows users, and case sensitive for the linux 

Of course I don't know what will happen if a linux user creates two 
files with the same name and different case, and then logs in from a 
windows workstation??!!


stefanke at wrote:
> Hi,
> the default value of case sensitive is auto! But no Windows OS supports case sensitiv filename so why don´t you use case "sensitive = no" helping to prevent problems?!
> Cheers Stefan
> -------- Original Message --------
> Subject: Re: [Samba]SOLVED - idmap_rid / roaming profile permissions / NTAUTHORITY\SYSTEM (01-Sep-2005 10:27)
> From:    sk at
> To:      samba at
>>I solved the problem with my roaming profiles by just changing from
>>case sensitive = yes
>>case sensitive = auto
>>in smb.conf!!!
>>No permissions change, no nothing.
>>Stefanos Karasavvidis wrote:
>>>I'm struggling with roaming profile permissions as I can not "see" the 
>>>I have:
>>>-samba file server with acl 3.0.14a
>>>-authentication with winbind and idmap_rid against Windows 2003 ADS
>>>-using "default domain" in smb.conf for winbind
>>>The roaming profile directories are on the samba machine under the users 
>>>home directory. As noted on several sites, the profile directory must 
>>>have the following permissions:
>>>owner full control (this is ok)
>>>SYSTEM (S-1-5-18) full control (here is the problem)
>>>I can't add the permissions for the system account, as it is "not seen" 
>>>from samba. The result is that roaming profile do not work
>>>I get the following output with wbinfo
>>>wbinfo -s "S-1-5-18"
>>>wbinfo -n "NT AUTHORITY\SYSTEM"
>>>S-1-5-18 Well-known Group (5)
>>>wbinfo -Y "S-1-5-18"
>>>Could not convert sid S-1-5-18 to gid   <--------
>>>wbinfo -S "S-1-5-18"
>>>Could not convert sid S-1-5-18 to uid   <--------
>>>I tried to fix it with net groupmap, but it did not work (maybe I miss 
>>>So the question is: how do I set permissions for the SYSTEM account???
>>Stefanos Karasavvidis
>>Electronic & Computer Engineer, M.Eng.
>>e-mail : sk at
>>Technical University of Crete, Campus
>>Information Systems Center
>>Address: Akrotiri, Chania, 73100
>>Tel.: Library Buildings
>>       (+30) 28210 37352, (+30) 28210 37355, (+30) 28210 37376
>>       Environmental Engineering Buildings
>>       (+30) 28210 37766
>>Fax:  (+30) 28210 37571
>>To unsubscribe from this list go to the following URL and read the

Stefanos Karasavvidis
Electronic & Computer Engineer, M.Eng.
e-mail : sk at

Technical University of Crete, Campus
Information Systems Center
Address: Akrotiri, Chania, 73100
Tel.: Library Buildings
       (+30) 28210 37352, (+30) 28210 37355, (+30) 28210 37376
       Environmental Engineering Buildings
       (+30) 28210 37766
Fax:  (+30) 28210 37571

More information about the samba mailing list