[Samba] Shares/connection disappears (bug?!)

Lars debs at utysket.dk
Tue Oct 25 14:56:50 GMT 2005


Im running Samba3 fileserver on Debian Sarge as a menber of a Ms win2003
AD. The samba-server gets it users/groups from the win2003 and hos the
users homefolder, a groupshare and a common share. But sometimes when the
users logs in they cant see any shares on the samba, exept the default
home (which the cant enter). I even tried sittinng with two workstations,
where one could see and use the shares, the other coldn't see anything..!
It's quite hard to always see a pattern.

FX right now, when the error appears again with one of the users, i can't
write "net ads user", it gives this:
linuxserver:/usr/script# net ads user
root's password:
[2005/10/25 16:47:02, 0] libads/kerberos.c:ads_kinit_password(146)
  kerberos_kinit_password root at SOS.NET failed: Client not found in
Kerberos database
[2005/10/25 16:47:02, 0] utils/net_ads.c:ads_startup(191)
  ads_connect: Client not found in Kerberos database

Then i run: #kinit Administrator at SOS.NET

And after that i can do a net ads user, but that error will come again
even if i don't reboot the server.
Th only other pattern i see, is that i typical happens "used" users, never
with a freshly added one...

The best would be to erase the server and reinstall, but i'm dont like 6
hours reinstallment time...


More information about the samba mailing list