[Samba] SambaBDC cannot join SambaPDC

Philip Washington phwashington at comcast.net
Fri Oct 21 02:26:14 GMT 2005

Philip Washington wrote:

> Craig White wrote:
>> On Wed, 2005-10-19 at 20:05 -0500, Philip Washington wrote:
>>> I have set up a Samba PDC migrating from NT4.  I can logon computers 
>>> and users that came from the old NT4 domain.  I began setting up a 
>>> SambaBDC following the directions in Section 5.5 of Samba3 by 
>>> Example.  Using samba3.0.20b on RHEL4
>>> whenever try
>>> # net rpc join -U root%secret
>>> or
>>> # net rpc join -S SAMBAPDC -U root%secret
>>> I get the following error
>>> ----------------------------------------------------------------------
>>> [2005/10/19 19:08:26, 0] rpc_client/cli_pipe.c:rpc_api_pipe(438)
>>>  cli_pipe: return critical error. Error was Call timed out: server 
>>> did not respond after 10000 milliseconds
>>> Creation of workstation account failed
>>> Unable to join domain DOMAINA.
>>> ----------------------------------------------------------------------------------------- 
>>> #net getlocalsid
>>> Can't fetch domain SID for name: SAMBABDC
>>> if I turn on the samba server and run smbclient //SAMBABDC/accounts 
>>> -Uuser1
>>> I can login and put a file in the share.  When I look at the 
>>> properties of the file  I see that it is owned by user1 and the 
>>> group is "Domain Users".  So it appears that samba is using the ldap 
>>> server correctly.
>>> #getent passwd
>>> #getent group
>>> appear to be returning the correct information when I compare it to 
>>> the directions.
>>> What and where else should I be looking for a problem?
>> ----
>> not enough info to do much more than guess but I did something stupid
>> that took me a few minutes to figure out.
>> I had a hosts allow = 192.168.1. statement and then when I tried to have
>> a user connect from a VPN, connections to the samba server would time
>> out because the remote host ip wasn't in the subnet
>> It might be something that simple
>> Craig
> I checked the hosts allowed and I didn't see a problem.
> I definitely have a problem now with ldap.  It has locked up and I 
> can't get even get a reply with slapcat. I am currently using 
> openldap_2.2.13-2 . This is RH version. 

Upgraded ldap to openldap_2.2.13_4 and this seems to have worked for 
now.  I was also able to get the SambaBDC to join the SambaPDC.

More information about the samba mailing list