[Samba] "Wbinfo -u" get user account sucessfully but "getentpasswd" fails

Felipe Augusto van de Wiel felipe at paranacidade.org.br
Fri Oct 14 19:28:47 GMT 2005

Hash: SHA1

Steve Zeng escreveu:
> Hmmm, I run it and the output make me confused:

> # pdbedit -L -v -u jho
> Username not found!

> # pdbedit -L -v -u szeng
> Username not found!

	pdbedit queries the samba user database. wbinfo
queries the winbindd. When you use getent the user is
not there, so, for some reason, it is not "crossing"
the line between winbindd and your environment.

> Then I tried "su - szeng", it successfully switched 
> into the user "szeng".

> Both "jho" and "szeng" are coming from Active Directory, 
> so do we need some other options when we run "pdbedit"?

	No, you don't need to use pdbedit, what you should
do is increase the log level of winbindd and try to figure
out what's going on when you query the jho user.

	I believe that you are not able to use "su - jho",
a few things come to my mind like 'nscd' and related cache
problems, also some communication delay. In any case, consult
the user accounts searching for differences sounds a
reasonable way to understand what is going on.

	You could also check for patterns, like creation
date, user behaviour, creation mechanism and things like
that, which should lead you to the root of the problem.

	Sorry if I don't have better answer for that.
Kind regards,

- --
// Felipe Augusto van de Wiel <felipe at paranacidade.org.br>
// http://www.paranacidade.org.br/
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Debian - http://enigmail.mozdev.org


More information about the samba mailing list