[Samba] Problems with smbpasswd, tdb_fetch_uint32 failed

Frank L. Parks fparks at ezbizpartner.com
Thu Oct 13 19:45:51 GMT 2005

Good Afternoon,

I had sent in an earlier message about trying to login and getting 
dropped from a W2000 workstation.  I received a reply back to upgrade 
Samba from 3.013 to 3.020x.  I did this.

Operating System: SuSE 9.3
Samba Version: 3.0.20a (SuSE's RPMs)

I am using /etc/samba/smbpasswd file and not LDAP to store the users and 

    passwd chat debug = Yes
    passwd chat = *password* %n\n *password* %n\n *changed*
    socket options = TCP_NODELAY
    logon drive = P:
    interfaces = eth1
    hosts allow =
    hosts deny = ALL
    domain master = Yes
    log level = 2
    log file = /var/log/samba/log.%m
    max log size = 50
    debug timestamp = yes
    username map = /etc/samba/smbusers
    map to guest = Bad User
    encrypt passwords = yes
    logon home = \\%L\%U\.9xprofile
    passdb backend = smbpasswd
;    printer admin = @ntadmin, root, administrator
    passwd program = /usr/bin/passwd %u
    wins support = yes
    printcap cache time = 750
    netbios name = smb
    cups options = raw
    printing = cups
    logon script = logon.bat
    unix password sync = True
    local master = Yes
    workgroup = CMC
    logon path = \\%L\profiles\.msprofile
    os level = 65
    printcap name = cups
    security = user
    add machine script = /usr/sbin/useradd  -c Machine -d 
/var/lib/nobody -s /bin/false %m$
    domain logons = Yes
    name resolve order = wins lmhosts hosts bcast
;    name resolve order = lmhosts hosts bcast
    dns proxy = yes

I then went back to the drawing board and started to run the samba 
tests.  On the windows client, I received a "System error 1326 has 
occurred" message when I attempted the net use x: \\server\username.  
The English translation of the message was "Login Failure: unknown user 
or bad password".  I googled this and rightfully or wrongfully, I 
thought that maybe there was a problem with the passwords 

I attempted to change the password of the user using smbpasswd and I 
received a dialog similar to this:

# smbpasswd <username>

New SMB password:
Retype new SMB password:
account_policy_get: tdb_fetch_uint32 failed for field 4 (maximum
 password age (seconds since 1970)), returning 0
account_policy_get: tdb_fetch_uint32 failed for field 5 (minimum
 password age (seconds since 1970)), returning 0

So I wondered if this was caused by the change from 3.0.13 to 3.0.30a.  
See http://lists.samba.org/archive/samba/2005-April/103603.html.  I used 
webmin to delete the user from /etc/samba/smbpasswd and it worked.  I 
then attempted to do a smbpasswd -a <username> and I got the same error 
as above.

I cannot add users to the system nor can I login into the domain.

Please help.  Thanks in advance,


More information about the samba mailing list