[Samba] Can't see Samba Server from Win2k

linux at magellanconsultinginc.com linux at magellanconsultinginc.com
Sun Oct 9 19:29:04 GMT 2005

I've read other posts on this, but can't figure out what I'm doing wrong. 

I have Suse 8.0, Samba 2.2.3a, and Win2k. 

Win2k Setup:
workgroup = HOME_NET
Host Name = Copernicus
IP :
Subnet :
Def Gateway: 

smb.conf (comments removed):
	workgroup = HOME_NET
	netbios name = gallileo
	encrypt passwords = yes
	security = share
	wins support = yes
	guest only = yes 

	username map = /etc/samba/smbusers 

	interfaces = 

	character set = ISO8859-15
	client code page = 850 

	veto files = /*.eml/*.nws/riched20.dll/*.{*}/ 

	comment = Home Directories
	read only = No
	browseable = No 

	path = /home/jimmy
	read only = Yes
	browseable = yes
	guest ok = Yes
	public = yes

I set up lmhosts as follows:
================================       localhost     copernicus     gallileo

I added my user name to Samba and can see it in the passwords file.  I used 
the same user name and password when logging into the Win2k box. 

Checking with smbclient gives me this:
Gallileo:/usr/bin # smbclient -L gallileo
added interface ip= bcast= nmask=
Domain=[HOME_NET] OS=[Unix] Server=[Samba 2.2.3a] 

       Sharename      Type      Comment
       ---------      ----      -------
       share1         Disk
       IPC$           IPC       IPC Service (Samba 2.2.3a)
       ADMIN$         Disk      IPC Service (Samba 2.2.3a)
       jimmy          Disk      Home Directories 

       Server               Comment
       ---------            -------
       GALLILEO             Samba 2.2.3a 

       Workgroup            Master
       ---------            -------
Gallileo:/usr/bin #

testparm shows the conf file is OK. 

When I log into the Win2k box as jimmy (again, same passwords as in Linux 
ans Samba), I can't see the samba server within the workgroup within My 
Network Places. 

I've tried restarting samba and rebooting the win2k box, but to no avail. 

I'm unsure of the "interfaces setting".  I have it set to the ip address of 
the Linux box.  I haev tried it with it commented out, but that didn't help. 

I have the firewall turned off. 

I can ping from both directions. 

At the moment, I'm not concered about security.  I'm just trying to learn 
for now and really just want to get the connection working. 



More information about the samba mailing list