[Samba] Samba Cups Windows 98 Raw Printing - need help

ds dsitsolutions at gmail.com
Fri Oct 7 15:45:45 GMT 2005

On 10/6/05, Craig White <craigwhite at azapple.com> wrote:
> On Thu, 2005-10-06 at 13:19 -0700, Joe Cipale wrote:
> > I have used both with and without '_' and I am still unable to get Samba CUPS printing to work... in either direction (linux <-> W2K). I can even get smbclient printing to work.
> ---
> make sure the host machine can print first
> Craig

I have tried replacing the underscores with a hyphens but still no luck.

I tested the printer on the local system.  If I send an ascii text
file to the raw queue it prints the text, but does not deal with
newlines correctly (not surprising, this is a raw queue).  Also, I've
created another print queue in cups that uses the correct hpijs driver
and sends output to the same printer (my only printer) and if I send a
text file to that queue it prints correct.  I can't send anything more
complex at the printer locally, since this computer is set up as a
file and print server it only has a basic Gentoo install plus Samba
and Cups, no X.org or OpenOffice installed.  Like I said before, it's
more likely a Samba issue, but it may be a Windows 98 issue as well. 
One of my next steps is to try updating or re-installing the Windows
print driver.


More information about the samba mailing list