[Samba] Rare problem using Samba and mounted directories

Carles Pina i Estany carles at pinux.info
Sun Nov 27 21:00:04 GMT 2005


I am a Samba user, and I have been using long time without any big

Last week I was working with a friend, using Fedora and Samba 3. Excuse me,
I don't know exactly which Samba version.

After some problems, we shared a directory (for example, /data). This
works, fine. Then we created two new subdirectories:

Then we access to shared resource using smbclient, without problems.

When we mounted other partition to one directory, it disappers of
smbclient listings! (not changing inside directory, just listing!).
Permissions was enough to list, and to go inside (I checked using su and
changing to samba user, etc.)

The error log, just _listing_ this directory it was:
get_lanman2_dir_entry:Couldn't stat [./a] permission denied 

I tried to use stat utility in a directory and b, without any problem.

I tried to do a little program and to use stat call without any problem.

I was confused, what it wrong? First time that I mount a partition to
directory and happends this rare things!

We was using 2.6 Kernel, original from Fedora, but I don't know exactly
the version.

I am sure that here somebody has had this problem and can send any
suggestion to me.

Thank you very much, 

PD: if it is needed tomorrow I will send Kernel version, Fedora Version,
Samba version. But maybe anybody has any suggestion.

Carles Pina i Estany		GPG id: 0x8CBDAE64
	http://pinux.info	Manresa - Barcelona

More information about the samba mailing list