[Samba] XP will no longer download print drivers

Michael Keightley Michael.Keightley at quadstone.com
Wed Nov 16 16:57:56 GMT 2005

We're using Cups and Samba with Adobe Postscript Drivers to print from XP SP2
machines via our Solaris and Linux Domain Controllers.  Everything has been
working OK, but when I setup an a new printer (identical ppd file to another
one), it doesn't download the drivers on XP when I add the printer.  
This is happening on two domain controllers in different offices.

It gives the error when I try to add a printer (non-admin user):

 A policy is in effect on your computer which prevents you from connecting to
  this print queue. Please contact your system administrator.

Printers that have previously been setup can be added to XP machine without any
problems.  I setup a test Samba domain on a SuSE 9.3 desktop, am getting the
same problems. 

Here are some details of my test machine.

Setup Cups (1.1.23) on SuSE desktop, added HP LaserJet 4050N to Cups using 
address ipp://lj162.quadstone.com/ipp

Used ppd file from XP for LJ 4050N.  Can print from SuSE OK.

Copied Adobe postsript drives into /usr/share/cups/drivers
% ls -l /usr/share/cups/drivers
total 2834
-rw-r--r--  1 root root  575573 2005-11-16 15:59 ADFONTS.MFM
-rw-r--r--  1 root root 1295840 2005-11-16 15:59 ADOBEPS4.DRV
-rw-r--r--  1 root root  196460 2005-11-16 15:59 ADOBEPS4.HLP
-rw-r--r--  1 root root  457600 2005-11-16 15:59 ADOBEPS5.DLL
-rw-r--r--  1 root root  135680 2005-11-16 15:59 ADOBEPSU.DLL
-rw-r--r--  1 root root   18451 2005-11-16 15:59 ADOBEPSU.HLP
-rw-r--r--  1 root root   13492 2005-11-16 15:59 DEFPRTR2.PPD
-rw-r--r--  1 root root   13492 2005-11-16 15:59 DEFPTR2.PPD
-rw-r--r--  1 root root  118128 2005-11-16 15:59 ICONLIB.DLL
-rw-r--r--  1 root root   57344 2005-11-16 15:59 PSMON.DLL

Setup Samba on SuSE machine.  Tried using the version that came with SuSE
(3.0.13) with the smb.conf that SuSE provides, also tried my own compiled
version of 3.0.20b with my own smb.conf.  Had same problem with both versions.
Have attached my smb.conf.

Created root user, added test user and PC trust account.  XP machine joined
domain OK.  Could login and see home files.
Ran "cupsaddsmb -a -v -U root" on SuSE box.  Drivers and ppd file got copied
into drivers/WIN40 and drivers/WIN40/0

% ls -F /home/samba_ted/drivers/WIN40

Have disabled Point-and-Print restrictions in XP via 
User Configuration\Administrative Templates\Control Panel\Printers in 

Logging in as test (non-admin) user, when I try to add the printer get above
error about "A policy is in effect on your computer which prevents...

If I login as administator and map a drive as the test user, then try to add
the printer it asks for print drivers.

Anyone got any ideas?  Have I missed out anything?


Michael Keightley <Michael.Keightley at quadstone.com>   Tel: +44 131 240 3137
Systems Manager, Quadstone Limited,                   Fax: +44 131 220 4492
16 Chester Street, Edinburgh EH3 7RA, Scotland        http://www.quadstone.com
-------------- next part --------------
  workgroup = TEST
  server string = %h
  interfaces =
  log file = /var/log/samba/%m.log
  load printers = yes
  printing = cups
  printcap name = cups
  domain master = yes
  domain logons = yes
  local master = yes
  preferred master = yes
  name resolve order = wins lmhosts host bcast
  wins support = yes
  os level = 65
  encrypt passwords = yes
  passdb backend = smbpasswd
  security = user
  logon script = netlogon.bat
  logon path = \\%N\profile\%a\%u
  logon drive = q:
#  socket options = TCP_NODELAY IPTOS_LOWDELAY

  comment = User Profiles
  path = /home/samba_ted/profile
  browseable = no
  guest ok = yes
  writeable = yes

  comment = All Printers
  path = /home/samba_ted/var/spool/public
  browseable = no
  public = yes
  guest ok = yes
  writable = no
  printable = yes

  comment = Printer Drivers
  path = /home/samba_ted/drivers
  browseable = yes
  guest ok = yes
  read only = yes
  write list = root

  comment = Home Directories
  browseable = yes
  guest ok = no
  writable = yes

  comment = Network Logon Service
  path = /home/samba_ted/%a/netlogon
  guest ok = yes
  writeable = no
  share modes = no

More information about the samba mailing list