[Samba] mapping with username: "user@domain" failed

Ephi Dror ephi at agami.com
Wed May 25 17:28:57 GMT 2005

Hi Paul,

Thanks for your reply.

I am not sure I understand. Most likely I haven't explained myself good

You said:
>Because it's an invalid syntax. In the windows world it's
DOMAIN\username, end of story.

I tested that syntax (name at domain) with mapping a share from windows
2003 server and this syntax is perfectly right and works like a Swiss

In fact, I thought that in complex environment with multiple domains and
sub domains and trusts between domain it should be very common to use
name at doamin and I thought that the syntax domain\name is more like a
pre-windows2000 syntax.

Of course I now that "domain" in the name at domain style meaning the
Active Directory domain name (what samba called realm name) and "domain"
in "domain\name" means the pre-windows (netbios name).

For example:

Active Directory domain name: london.agami.com
Pre-windows2000 domain name: london
User name: ephi

Now I have samba server that joined this domain in ADS style.
I also have another win2003 that joined that domain.

Samba and the other windows 2003 server both have one share each.

When I go to winxp client to map those shares I can use both styles
(ephi at london.agami.com and london\ephi) when prompoted to put

HOWEVER, samba does not like me to use ephi at london.agami.com, ONLY
london\ephi worked.

I hope I explained my point better.

I guess, all I am asking is why samba (maybe only my samba) server
doesn't allow me to use "name at realm", meaning only "netbiosDomain\name"



-----Original Message-----
From: Paul Gienger [mailto:pgienger at ae-solutions.com] 
Sent: Wednesday, May 25, 2005 5:45 AM
To: Ephi Dror
Cc: samba at lists.samba.org
Subject: Re: [Samba] mapping with username: "user at domain" failed

>When trying to map my SAMBA share from WinXP, it prompted me for name 
>and password but it failed when I used name at domain.com However,  using 
>"domain\name"  worked.
>Any idea why my SAMBA server didn't accept this name style  name at domain
Because it's an invalid syntax.  In the windows world it's
DOMAIN\username, end of story.  Also, is your windows domain named
domain.com (substituting real values of course) as opposed to just
domain?  If so you're probably also seeing plenty of errors with joined
machines looking for DNS entries that would only exist in an LDAP setup.

Paul Gienger                    Office: 701-281-1884
Applied Engineering Inc.
Systems Architect               Fax:    701-281-1322
URL: www.ae-solutions.com       mailto: pgienger at ae-solutions.com

More information about the samba mailing list