[Samba] cupsaddsmb problem

Julian Pilfold-Bagwell jpb at bordengrammar.kent.sch.uk
Fri May 13 10:39:19 GMT 2005

Hi all,

I have a problem with adding point and print to a print server. The server 
details are as follows:

700MHz Celeron + 384MB RAM
Mandriva LE2005 (Mandrake 10.2)
Samba 3.0.13-2mdk
CUPS 1.1.23
cups drivers 10.2-0.11
gimpprint-cups 2-1.1.23-11
foomatic 3.0.2-1

The server is bound to an NT4 based domain (to be replaced with Linux/Samba in 
the summer) and winbind works fine with wbinfo -u and -g returning a full 
list of users and groups.

Cups works fine printing from Linux clients but when I run cupsaddsmb to 
deliver the drivers to the XP client machines it fails to copy the files to 
the named folder.

Running the command gives the output below:

[root at ourschool printers]# cupsaddsmb -U jpb -h localhost  HPLaserJet5L
Password for jpb required to access localhost via SAMBA:
[root at ourschool printers]#

Running it in verbose mode only gives the following:

[root at ourschool printers]# cupsaddsmb -U jpb -h localhost -v HPLaserJet5L
Password for jpb required to access localhost via SAMBA:
Running command: rpcclient localhost -N -U'jpb%pwchanged' -c 'setdriver 
HPLaserJet5L HPLaserJet5L'
Succesfully set HPLaserJet5L to driver HPLaserJet5L.

the final line of which suggests it's worked but the drivers aren't copied to 
the /var/lib/samba/printers folder and the clients can't find the drivers 
when p+p is tried.

The smb.conf is shown below:

        workgroup = SCHOOL
        server string = A1-lptserver
        netbios name = A1-lptserver
        security = domain
        encrypt passwords = Yes
        password server = NTServer
        public = yes
        browseable = yes
        lm announce = yes
        browse list = yes
        auto services = yes
        log file = /var/log/samba/log.%m
        max log size = 50
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        unix charset = ISO8859-15
        os level = 20
        local master = No
        domain master = No
        preferred master = no
        dns proxy = No
        idmap uid = 10000-20000
        idmap gid = 10000-20000
        winbind enum users = yes
        winbind enum groups = yes
        template homedir = /home/%D/%U
        template shell = /bin/false
        winbind use default domain = yes
        hosts allow = 10.88.8. 10.88.9. 10.88.10. 10.88.11. 127.
        remote announce =
        load printers = yes
        printcap name = cups

        comment = Printer Drivers
        path = /var/lib/samba/printers
        browseable = yes
        public = yes
        write list = bm,ew,jpb,@"Domain Users", at adm

        comment = All Printers
        path = /var/spool/samba
        browseable = yes
        public = yes
        printer admin = bm ew jpb root @"Domain Users"
        guest ok = yes
        printable = yes
        create mode = 0700

and the permissions are set as follows on the /var/lib/samba/printers folder:

drwxrwxr-x   7 root domain admins 4096 May 10 15:13 printers/

with the same on the subdirectories.  jpb, bm and ew are named as allowed 
users in the write list and all three are also members of the domain admins 

Any help with this greatly appreciated. I get the feeling that it's something 
really obvious that I'm overlooking but I've been going round in circles and 
can't see the wood for the trees.


Julian PB

More information about the samba mailing list