[Samba] samba 3.0.14a + solaris acls

Felipe Tocchetto tocchetto at gmail.com
Fri May 6 17:12:38 GMT 2005

Hi all

Yesterday i tried to update my samba to version 3.0.14a (we were using 
3.0.10 without acl support) in a Solaris 8 server. I compiled with 
--with-acl-support option. Everything runs ok during the installation, but 
after I start the new samba some users can´t rename, edit or delete files in 
their shares, but they can create files. 
I do some tests over MS Word and Excel, creating new files direct in the 
share, they can only do all operations if the user is the owner of the 
directory, but when I try a getfacl in the directory, all the permissions 
are ok.

I searched over the web and I find this: 

this thread talks about a similar problem, but in my case, isn´t all users 
afected. Today I put the old version of samba back, without acl support. I 
tried to patch my samba source, but it didn´t work.

Anybody knows what versions of samba have this problem with solaris ACLs?

Felipe L. Tocchetto
msn ftocchetto at hotmail.com
icq 163263160
felipe at tocchetto.com

More information about the samba mailing list