[Samba] LDAP Logon Problem

Robert Schetterer robert at schetterer.org
Mon May 2 23:26:30 GMT 2005

Sascha Bieler schrieb:
> Hi everybody,
> I got a strange problem. I'm using fedora core 3 and openldap. Configured
> samba 3.0.11 to act as LDAP PDC and everything worked fine.
> But now creating a new user and trying to log on I get:
> check_ntlm_password:  Authentication for user [florian] -> [florian] FAILED
> In LDAP there seems to be everything fine, but I cannot manage to logon with
> a new user. The old ones are working fine.
> Greetings and thanks for helping out
> Sascha
Hi Sascha,
i had simular problems with setting samba 3.0.14a ldap on suse 9.3
at last i got it run but it was a march trough hell, none of my methods
which allways worked throug all releases of samba 3 on suse 9-1-2 which
ever worked fine, dont worked as expected
it seems to me something really broke between samba ldap idealx-scripts
and nss_lib and it only get to work if you have the right releases
matching, and suse has totally reconfigured pam modules ( which is nice
described on a html page , but didnt worked at first....the yast way)
But this is just an idea, this time i taked me 2 days to init the ldap
pdc ( which nerver happend before )...i had done this same setup last
week with suse 9.2/smb7ldap 3.013 in one hour..
Anyone else who noticed problems like that, i would write it to bugzilla
but i have no idea why it worked at last....one thing but seems clear
the 3.015 beta has bugs with usrmgr ( i had no chance to get it work )

Mit freundlichen Gruessen
Best Regards
Robert Schetterer

Munich / Bavaria / Germany

\* gnupgp
\* public key:
\* https://www.schetterer.org/public.key

More information about the samba mailing list