[Samba] Samba does not 'see' all the cups printers

Bert_De_Ridder at peopleware.be Bert_De_Ridder at peopleware.be
Tue Mar 29 13:09:03 GMT 2005

Hi, all,

I have a weird problem; I have 3 working cups printers on Suse linux 9.
All 3 are networked printers. 

I use the following statements in smb.conf : 
        printing = cups
        load printers = yes
        printcap name = /etc/printcap

        comment = SMB Print Spool
        path = /var/spool/samba
        guest ok = yes
        writeable = no
        public = yes
        printable = yes
        browsable = No
        printer admin = root, bdridder
        use client driver = Yes

this is the content of /etc/printcap

# This file was automatically generated by cupsd(8) from the
# /etc/cups/printers.conf file.  All changes to this file
# will be lost.
HP-Laserjet-4000|Developers gelijkvloers - soms platvloers 
HP-LaserJet-4100|Sales & Marketing:rm=GOSCINNY:rp=HP-LaserJet-4100:
HPCL2500|Colour Laserjet - use only when needed:rm=GOSCINNY:rp=HPCL2500:

If I use printcap name = cups in smb.conf, NO printers show up at all.
If I use /etc/printcap, only HPCL2500 shows up in the Printers folder of 
the server. 

Does anybody have an idea how this can happen ?


Bert De Ridder

PeopleWare NV - Head Office
Cdt.Weynsstraat 85 
B-2660 Hoboken 
Tel: +32 3 448.33.38 
Fax: +32 3 448.32.66 

PeopleWare NV - Branch Office Geel
Kleinhoefstraat 5
B-2440 Geel
Tel: +32 14 57.00.90
Fax: +32 14 58.13.25


John H Terpstra <jht at samba.org> 
Sent by: samba-bounces+bdr=peopleware.be at lists.samba.org
16/03/2005 17:34
Please respond to
jht at samba.org

samba at lists.samba.org

Re: [Samba] Samba and LDAP Base DN


If your binddn has changed you need to re-run:

                 smbpasswd -w 'secret'

to update your secrets.tdb file.

- John T.

On Wednesday 16 March 2005 09:06, Misty Stanley-Jones wrote:
> More info: I tried deleting ou=corp (after making a backup of course) 
> still no dice.  As soon as I put back ou=corp and make the baseDN in
> smb.conf ou=corp, everything works.  If I take all the entries under
> ou=corp and copy them one level up, I can't authenticate to Samba 
> It doesn't make any sense.
> On Wednesday 16 March 2005 10:57 am, Misty Stanley-Jones wrote:
> > Right now, I have all of my Samba stuff under
> > ou=corp,dc=mycompany,dc=com. I have it this way because there used to
> > also be
> > ou=furn,dc=mycompany,dc=com with a different domain.  Now that I only
> > have one domain, I would like to move everything to 
> > So I copy all of the subentries of ou=corp (ou=computers, ou=people,
> > ou=grooups, and the sambaDomainName entries) to dc=mycompany,dc=com. I
> > change the /etc/ldap.conf files to all point to the new OU.  Perfect. 
> > However when I change the baseDN in my smb.conf, all of a sudden I 
> > authenticate. Even when doing smbcontrol smbd reload-config.  The only
> > thing I can figure is that it might be doing a 'sub' search and 
> > two entries for my user, because I left the 'ou=corp' DN as it was. Is
> > it that, or is there something else I have to do in order to 
> > my LDAP tree?
> >
> > TIA,
> > Misty

John H Terpstra
Samba-Team Member
Phone: +1 (650) 580-8668

The Official Samba-3 HOWTO & Reference Guide, ISBN: 0131453556
Samba-3 by Example, ISBN: 0131472216
Hardening Linux, ISBN: 0072254971
Other books in production.
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list