[Samba] smbmount problem

Leo leo at secline.com.br
Mon Mar 28 18:44:18 GMT 2005

Hello all:

I have an annoying problem with smbmount; My Win2k server has many 
folders and files named with accented characters (cp850 and/or cp860 or 
European w/0 euro or Portugese).
My mount command is:

mount -t smbfs -o username=leo,codepage=cp850 //<servername>/d$ /mnt/pt

to mount my d: drive at /mnt/pt

I am prompted for my password and the shared folder is mounted.  I can 
see all files and folders and navigate them except for that I noticed

Á appear as A
ã and õ appears as a and o

Most other accented chars like ç, á, é, í, ó, à, è, ì, ò all seem to 
appear correctly.

these files (when listed explicitly) return an error as though the file 
didn't exist (logical since the real names are different, accented).

I have tried specifying an iocharset (iso8859-1) smbmount parameter but 
nothing really changes.

My kernel nls support is ISO-8859-1 by default (the default if I 
remember correctly)
My dos charset (smb.conf) is 850
display and unix charsets are set to ISO8859-1

When I run smbclient -U leo //<servername>/d$

The ftp like command program displays all characters correctly.

Does anyone have any suggestions as to how to correctly display accented 
from a Win2k served folder mounted on a linux filesystem?  I have 
exhausted all possibilities I can think of.

Thanks in advance,

More information about the samba mailing list