[Samba] SWAT and cups printing.

Greg Folkert greg at gregfolkert.net
Tue Mar 22 16:01:02 GMT 2005

On Tue, 2005-03-22 at 10:27 -0500, Greg Folkert wrote:
> Sorry for the resend, if this is. I got an error on the first one.
> I have been using swat for a really long time. This is the first I have
> ever REALLY caught it doing something wrong.
> In the latest version of SAMBA, with swat compiled at the same time
> (with the explorer patch added afterward) I am fairly certain, I have
> found and issue.
> I am tooling along, I use swat to add a share. No problems, share works
> fine.
> About 10 minutes later, I start getting phone calls... about printing
> failing. I try with my linux machine... no problems, cups is working,
> must be samba.
> Samba config looks fine to me, I restart it, still no printing. Well, I
> get the people who MUST print now working using client side printing to
> cups (not pretty on Win9X)
> So, I start twiddling with the advanced printing area. Set to cups. misc
> option... commands all look good. Commit.
> Still no printers. I look at smb.conf. Hmmm, takes me about 3 minutes to
> deduce the problem.
> When SWAT wrote the smb.conf, set with printing = cups through SWAT, the
> declaration is _*GONE*_. Since there is #No default# setting. All
> printing goes away. I switch it to BSD temporarily... printing starts as
> I have BSD print emul going to for a few legacy *NIX machines. I look at
> the conf... it shows "printing = bsd" I think GREAT it just needed a
> change, I wait for printing to catch up.
> I use swat to change smb.conf to "printing = cups", printing falls over
> again. Looking through smb.conf... the *IS* no "printing =" anymore. I
> add it manually, restart samba. Voila We are good to go. Time to stay
> away from Swat for a bit. Anytime you commit anything through SWAT it
> removes the "printing = cups" unless it isn't set at "printing = cups"
> then it leaves it.
> This is a BIG pain. Any chance someone could look over it. I couldn't
> find a problem with a cursory check (using grep and a few patterns I
> sort of expected to find) and gained no insight.
Opened this defect report. Minor, but a real pain.


greg, greg at gregfolkert.net

The technology that is
Stronger, better, faster: Linux
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.samba.org/archive/samba/attachments/20050322/8876a558/attachment.bin

More information about the samba mailing list