[Samba] add machine script = ... does not work?

Bostjan Müller neonatus at gmail.com
Tue Mar 22 13:57:02 GMT 2005


I have a pdc on samba 3.0.9 with LDAP as backend.
However when I add a machine to domain (via the Windows interface - my

The computer is added to the domain (into ldap), but only via
samSambaAccount, and no posix parts.

I have tried to use:
add machine script = /usr/local/bin/smbldap-useradd.pl -w "%u"

And nothing happened - it works just fine if I run it manually. Than I tried:
add machine script = /bin/echo %u >> /tmp/addmachine.txt

and again nothing happened, but the machine account exists in ldap at
that point (allthough I deleted it before joining the domain).

Is there anything more that one would have to do to make samba execute
those scripts (I was joining the domain via root account (uid=0,

Please help me if you can, because I do not know what to look for any
more (logs also show no errors or clues at this point).

buhdej evridej

More information about the samba mailing list