[Samba] Trouble samba sharing a read-only nfs mount

Jacob Anawalt jlanawalt at gmail.com
Thu Mar 17 05:58:08 GMT 2005


I've been using samba for a few years now sharing files from the local
filesystems without a hitch. Recently I have tried to throw into the
mix read only samba shares of read only nfs mounts. I can browse these
shares but any attempt to copy files from them seems to reset the
connection. Windows says the resource is unavailable.

On the Debian system that is sharing the file I see that these resets
leave smb processes that don't exit for whatever user tried to copy
from the share. I have dozens of them hanging around four hours after
the last time I had tried to connect during which time the windows
machine has been powered off. I see other smb processes that are days
old from when other users have tried to copy from the same shares.

What settings are required to make a read only samba share work on a
read only nfs mount? I have tried faking or not using optlocks in the
shares and of course writable=no.

Does it matter that the nfs mounted share is a local nfs export? I was
experimenting with rsync snapshot backups to provide 'support
yourself' backups to users as described here:

I think this would have been covered/solved somewhere but it seems to
be beyond my searching skills. I saw many posts talking about how
samba sharing a nfs read only mount should work fine, but no details
of the configuration or issues similar to mine.

Thank you for your time and advice,
Jacob Anawalt

More information about the samba mailing list