[Samba] Problems with MS Office (Excel/Word) & Samba 3.0.11, (moved to testing 3.0.12-RC1) attn Jerry

david rankin drankin at cox-internet.com
Wed Mar 16 03:32:47 GMT 2005

>> Tried disabling/veto'ing oplocks, but to no avail, so we've opted to try
>> 3.0.12-rc1 on one of the two servers; all is well at this point thus far
>> (been running about 10mins), figured I'd drop the list a line; Just a 
>> note -
>> we've been having huge problems with MS Excel and Word running on samba
>> 3.0.11, moved over to 3.0.12-rc1, (even though this is a production
>> environment).
> Please be exact on the version of MS-Office you're running with. I can't
> reproduce the problems with a MS-Office 2003 - if you're running an 
> earlier
> version I'll need to go back a rev or so.
> Jeremy.


    I don't know if this is related, but I am still having fits in Office 
2003 with the file open dialog hanging for 30 seconds when trying to open 
files. The recent exchange is shown below:

>From: "Linwei Cheng" <hcheng at sjgeophysics.com>
> Hello,
> The issues I had before seems all disappeared after I rebooted my
> machine( Fedora3, kernel 2.6.10-1.770_FC3 ). I don't really understand
> what benefited the samba on rebooting... The information is, before this
> reboot, I updated the kernel from 2.6.10-1.760_FC3, and updated samba from
> 3.0.10 to 3.0.12pre1-1.
> I really doubt it's the client requirement of "GET FULL FS SIZE" caused
> the slowness. Before rebooting, I tried using smbclient on another linux
> machine to connect the shared folder on samba server, and found that when
> I use "ls" to list the directories, the directories can be returned
> immediately but it get stuck on display the "filesystem size" information
> at the bottom until timeout. I think it's the same issue for "mapping" a
> disk on windows machines, since the windows will try to grab "filesystem
> size" information on every operation as well.  After rebooting, the "...
> block of size ..... blocks available" returned immediately and everything
> goes smoothly.
> linwei

    I am seeing the exact same problem and I can confirm that a reboot of
Win XP helps the problem temporarily. (this is my laptop so it is restarted
regularly) It seems something is getting cached or stuck somewhere after XP
is up and running for a while that is causing the 30 second delay descending
down the directory tree when using the "file-open" dialog from MS office
applications. There is nothing on the MS lack of knowledge base and google
hasn't been my friend on this issue. Do you have any other ideas that might
help get this issue resolved??


More information about the samba mailing list