[Samba] New HP Printer Drivers wont upload (samba 3.0.11)

Phil Burrow philburrow at blueyonder.co.uk
Tue Mar 15 10:53:49 GMT 2005

Luca Olivetti wrote:
> Phil Burrow wrote:
>> Is there a fix? Is it just that HP's new drivers don't work with Samba? 
> Yes, probably. The only printers that gives me problems here are hp 
> printers. Other printers we have here gave me no problem at all.
> For a deskjet 5800 I had to use the linux driver (foomatic/hpijs) and 
> load the adobe ps driver, its windows driver would upload fine (in samba 
> 3.0.10, the same error as you with samba 2.2.8) but then give plenty of 
> exceptions on the windows client (to the point that I had *no* way to 
> access the printer or remove it: I had to do it on the server using 
> rpcclient).

I hadn't really noticed any problems with drivers until I came across 
this problem, because most of our printers are relatively old (LJ 4000) 
and the drivers worked. But since we got a couple of Laserjet 4200tn and 
4250tn it's been extremely frustrating.

I did manage to make it take the LJ4200tn driver on a different server 
running 3.0.10, but I did have this exact problem for a while on there. 
I must have just done something by accident and it just worked. That's 
why I thought there may be a trick.

But other drivers do work so I don't think I'm doing anything wrong..


More information about the samba mailing list