[Samba] usermgr generates error when adding new group

Doug Campbell doug at bpta.net
Tue Mar 15 03:55:40 GMT 2005

I have Samba 3.0.12pre1 setup and working well so far.  The current issue is
when I run usermgr.exe to Manage Users and Groups.  Managing Users works
great.  Managing Groups presents some errors.

For example,

Login with account that has been granted "SeAddUsersPrivilege".
Create a Group named "Test"
Click OK

Receive message "Access Denied".

Click OK
Refresh list of groups.
"Test" is now a valid group.

Next try add a user to the Group by doing the following:

Edit Group by double-clicking on it
Add user Tester to Group
Click OK

Receive message "Access Denied".

In this case, no change was made.

Instead, double-click on user Tester's entry
Click on Group button
Add Group "Test" to Tester's groups
Click OK

Everything works.

Sergey Loskutov mentioned this same error in a previous post and it was
indicated that 3.0.12pre1 might have a fix for this.  It doesn't seem to.

This is a bug, right?  When might it be fixed or how can I follow up on it
to know when it has been fixed?


Doug Campbell

More information about the samba mailing list