[Samba] New HP Printer Drivers wont upload (samba 3.0.11)

Phil Burrow philburrow at blueyonder.co.uk
Mon Mar 14 19:55:47 GMT 2005

Maybe there's a trivial solution to this, but it's confused the hell out 
of me.

I'm trying to upload the latest Windows XP PCL6 driver for our Laserjet 
4250TN to my Samba 3.0.11 server. It works, and uploads the driver 
files, but then at the end it produces an error on the XP client "the 
operation could not be completed". The logs on the samba server state:

move_driver_to_download_area: Unable to rename [W32X86/HPC4250C.INI] to 

I've tried the PCL5e and PS drivers and I get similar errors. The 
filename it's complaining about does get uploaded, as I spammed 'ls' 
when it was uploading to the server and saw it, but upon error a small 
number of files end up in the W32X86/3/ and the rest of them disappear.

But bizarrely if I try the Laserjet 4000 series PCL6 drivers, they work 
absolutely fine. Fortunately for me this driver is entirely compatible 
with the LJ 4250TN printer. But I'd still like to get the proper driver 
on there if possible.

I've tried:

-Clearing the tdb files.
-printer admin = root, @"Domain Admins" in global instead of printers/print$
-Logging on as different users (but all in printer admin) - it seems 
only Administrator/root has the option to upload a driver as it's greyed 
out even for people in printer admin. I guess this is a recent Microsoft 
restrictware patch and I'll have to plough the registry to change it.

Is any of this a known issue?

Is there a fix? Is it just that HP's new drivers don't work with Samba? 
Out of interest I tried uploading random drivers and some would upload 
and some wouldn't (giving the same error as above if they wouldn't).

Appreciate any guidance!



More information about the samba mailing list