[Samba] Excel File Open Issue - Possibly Samba Related

klubarpop klubarpop at emiboston.com
Wed Mar 9 14:54:29 GMT 2005

We were having the same problem with Excel ... Different version of Samba.
Applying a fix detailed in MS KB # 324491 solved the problem for us.  (We
use Office 11 although the fix talks about Office 10  -- Office 11 = Office
2003  Office 10 = Office XP for those who don't keep up with such things.)

Do a search for QFE_Saskatchewan for the registry key.  Anyone have any idea
why the key is named Saskatchewan?

Hope this helps
Ken Lubar

-----Original Message-----
From: samba-bounces+klubarpop=emiboston.com at lists.samba.org
[mailto:samba-bounces+klubarpop=emiboston.com at lists.samba.org] On Behalf Of
Chad Vincent
Sent: Wednesday, March 09, 2005 9:39 AM
To: samba at lists.samba.org
Subject: Re: [Samba] Excel File Open Issue - Possibly Samba Related

Hash: SHA1

Okay....  Problem did not go away.  I un-shared (multi-user) the file to
clear out the changelog, and the problem did go away.  At this point I'm
going to assume a malformed entry in the changelog or a changelog that was
just too darn big.  (Before, size was 25MB, after removing sharing it was
2.5MB and opened in 1/8th the time.)

HOWEVER, upon upgrading to 3.0.11 as suggested, now ALL shared
(multi-user) Excel files are, at apparent random, displaying a message "This
file has been locked.  To save changes you must save under a different file
name and merge....(blah, blah)"  We never had this problem under 3.0.7.  I
have "log level=1" and nothing is showing up in the logs.

(Just for example, user A opens purchasing.xls fine, but B gets the error.
B can open schedule.xls fine, but A gets the error.  C can open both.  Have
not seen this behavior on non-shared files.)

These files HAVE to be shared, and I have even tried with veto
oplocks=/*.xls/ with no apparent change.

Jeremy Allison wrote:
> On Tue, Feb 22, 2005 at 02:45:43PM -0500, Chad Vincent wrote:
>>Hash: SHA1
>>Having a workstation with an odd glitch, and I'm hoping someone can 
>>help.  We have a 35MB shared Excel file with our purchasing history in 
>>it.  (I know, I've been trying to talk them into a database of some 
>>sort, but they'll have none of that...)
>>One workstation in the entire plant is having issues opening it.  The 
>>file will load, it will change status to [Shared] in the titlebar, 
>>then stop.
>>Bad Workstation:
>>Windows 2000
>>Athlon 1600+
>>256MB DDR 333
>>Soyo Dragon KT333 Ultra Black
>>Realtek 8139 on-board (Also tried PCI 8139)
>>Debian Stable
>>2x Opteron 240
>>Broadcom "tg3" 1000Mb NIC
>>Samba 3.0.7-1 as a PDC
> You need to upgrade. There have been several fixes in this area to do 
> with the rather strange way Excel uses SMB. None of them should cause 
> the client to disconnect, although a deferred open problem could 
> conceivably do this. It's just that many people are reporting much 
> better results with Excel and 3.0.11.
> Jeremy.

- --
Chad Vincent
chad at rhiannonweb.com
Version: GnuPG v1.4.0 (MingW32)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org


To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list