[Samba] AIX/Samba vs. Large Files

Cameron Hanover chanover at umich.edu
Wed Mar 9 13:53:49 GMT 2005

/etc/security/limits has fsize at -1, and i've used chuser to make sure 
all the users are set the same [some were created before I figured that 
part out].

Unfortunately, I didn't set up anything on this machine initially, I'm 
just trying to figure it out after the fact.  [I've run linux servers, 
so they thought I could do AIX administration.]

Anyway, it looks like you may be on to something:
/dev/lv01       --         /ancept                jfs   41156608 rw     
    yes  no
   (lv size: 41156608, fs size: 41156608, frag size: 4096, nbpi: 4096, 
compress: no, bf: false, ag: 8)

What's weird, though, is scp can copy a 1296MB file to that mount, but 
Samba can't.  Is there a way I can set bf=true without losing all the 
data on it?


So shines a good deed in a weary world.

On Mar 9, 2005, at 8:43 AM, William Jojo wrote:

> On Wed, 9 Mar 2005, Cameron Hanover wrote:
>> I'm having trouble getting Samba 3.0.11 working properly on AIX
>>  I've got a share set up, and I can connect fine, but I can't
>> get it to transfer files >1GB.  I've already set ulimit fsize to -1,
>> and I can transfer large files via scp to the same directory just 
>> fine.
>>  The directory is on a JFS volume.  There are no quotas on this 
>> system.
>>   I've even tried adding -D_LARGE_FILES to the cppflags [there was one
>> google hit that mentioned that].  The log files tell me nothing [with
>> loglevel ranging anywhere from 1-5].  The Max Volume Size is set to 0.
>> When the configure script is run, it says "checking if large file
>> support can be enabled... yes".  According to config.log: #define
> What does your /etc/security/limits look like?
> Also did you create the FS with large file support? JFS by default does
> not have this turned on. Did you create this with mkfs or smit?
> If it was mkfs the "-o bf=true" needed to be used and the fragment size
> must be 4096.
> Bill
>> When I try it from OS X, it'll transfer until it hits 1GB, then it'll
>> report the disk is full, and delete the file.  From command line
>> smbclient, it does the same, but doesn't delete the file, and tells me
>> "NT_STATUS_DISK_FULL".  From Windows XP, it just reports that there's
>> not enough space before the transfer starts.  The disk has 13GB free.
>> I've also tried 3.0.9 and got the same results.
>> Any thoughts on what I could try next?
>> -c.
>> So shines a good deed in a weary world.

More information about the samba mailing list