[Samba] hostnames resolve to wrong IPs - and sometimes sharesbecome inaccessible

Rod.. Whitworth listen at witworx.com
Mon Mar 7 11:56:19 GMT 2005

On Mon, 7 Mar 2005 16:20:59 +0800, Doug Campbell wrote:

>> Environment: OpenBSD v 3.6 Release, Samba ver.: Samba 3.0.5
>> LAN:, Samba servers: 2 installed replacing
>> workgroup peer shares
>> Windows version: XP Pro
>> History: The 2 Sambas were installed last year and appear to have
>> operated well until recently. Client admin now
>> reports that, after some time connected to a shared directory,
>> searching for files results in a Win error message to
>> the effect of: Cannot access s:\ - Access is denied. Rebooting
>> the Windows box allows access again.
>> I cannot figure the possible cause except that WinXP was updated
>> ~about~ the time the problems began. Need I
>> say that they have no idea what function was affected by the update.
>> Accessing remotely I see some strange behaviour. Running smbtree
>> results in several errors about not being able
>> to connect to some addresses that are remote.
>> A snip of one message appears below:
>> =====
>>         \\FIFTY                         Cosmo
>> Error connecting to (Invalid argument)
>> cli_full_connection: failed to connect to FIFTY<20> (
>> =====
>> That machine should be at as shown by the nmblookup below:
>> =====
>> # nmblookup fifty
>> creating lame upcase table
>> creating lame lowcase table
>> querying fifty on
>> fifty<00>
>> =====
>> I do not know if this is in any way connected because I had no
>> reason to look at it before. I can connect, to the
>> machines that throw errors in smbtree, using smbclient with the
>> -I <IP address> option.
>> Are these conneccted?
>> What do I need to do to resolve the problem/s ?
>> More diagnostics needed?
>> Standing by.....
>> I have 2 other clients with the same platform and mixed win
>> versions reporting no problems.
>> >From the land "down under": Australia.
>> Do we look <umop apisdn> from up over?
>> Rod/
>I had a similiar problem to yours, I believe.  It was caused when I switched
>the IP address on my samba box.  I stopped samba.  Renamed the gencache.tdb
>and wins.dat files located at /var/cache/samba.  Started samba back up.
>Everything worked fine after that.  For me these cache files were causing
>the old settings to stay around.

I should have said that I tried grepping for the false IPs everywhere I
thought they might be and then I checked the source code to see if it
was ceratin that gencache.db would be recreated and did that. I also
blew away all the /var/log/smbd.* files too and both Sam servers came
up again with the same nonsense. I also deleted the wins.dat file - no
change. I kinda get the idea that thes boxen get the map from some
other perverted machine on the LAN.

The IP has never changed on the LAN or these boxen, so that isn't the
key to the onset.

It is <very> bizarre.

>From the land "down under": Australia.
Do we look <umop apisdn> from up over?

Do NOT CC me - I am subscribed to the list.
Replies to the sender address will fail except from the list-server.

More information about the samba mailing list