[Samba] SWAT login fails

Robert Vangel vangelr at rfgt.net
Thu Jun 30 12:02:04 GMT 2005

Jared Wiltshire wrote:
> Hi,
> I'm a linux newbie so be nice.
> I have recently installed a Smoothwall Express 2 firewall with fixes7, and 
> am trying to get a Samba server to run on this machine.
> I compiled the lastest stable release of samba on this machine and it seemed 
> to go fine. I then compiled xinetd and configured the xinetd.conf file for 
> Using a putty SSH session I ran the the command xinetd -d to start xinetd 
> and therefore SWAT. I think this is how it works. (BTW, how do I run xinetd 
> in the background?)
> The problem is that when I enter http://hostname:901 into my browser and try 
> to login with my root username and password the login doesnt work. The login 
> box just keeps popping back up.
> If someone could help me out with this it would be great. Thanks.
> - Jared Wiltshire

swat uses the samba usernames, so you first need to issue `smbpasswd -a 
root' if you haven't done so already.

More information about the samba mailing list