[Samba] unknown auth type 9

Don Watson dwwatson at us.ibm.com
Mon Jun 27 13:55:19 GMT 2005

Hmmm, now I'm using 3.0.20pre2-SVN-build-7944, and I still have the problem.

In smb_io_rpc_hdr_auth, prs_uint8 parses out the auth type as "9"; is this a 
value that is coming from Windows?  I have tried changing various security 
settings on the Windows system, with no results.


On Monday 27 June 2005 08:27, Gerald (Jerry) Carter wrote:
> Don Watson wrote:
> > In the archives I have found that "unknown auth type" was a
> > known problem  which should have been fixed in 3.0.14a.  I
> > am running 3.0.15pre2 on SLES9.   The client is running Microsoft
> > Windows Server 2003, Standard Edition, with  Service Pack 1.
> >
> > Is it possible I have something misconfigured (unconfigured?)
> > in smb.conf?
> Nope.  It was my goof.  jeremy fixed it.  Should be ok in
> 3.0.20pre1 (or the latest SAMBA_3_0 svn tree).
> cheers, jerry
> =====================================================================
> Alleviating the pain of Windows(tm)      ------- http://www.samba.org
> GnuPG Key                ----- http://www.plainjoe.org/gpg_public.asc
> "I never saved anything for the swim back."     Ethan Hawk in Gattaca

Don Watson

More information about the samba mailing list