[Samba] Windows 2003 AD users not found

Kyle Johnson kyle.johnson at revisor.leg.state.mn.us
Wed Jun 22 20:34:18 GMT 2005

Joseph Preston Schmigel (RIT Student) wrote:

>I recently changed from Windows 2000 native active directory mode to
>Windows 2003  active directory mode.  When I did that, users could no
>long connect to any of the Samba shares.  They were prompted for a
>username and password.  The following error was logged in the winbind
>[2005/06/22 14:38:46, 1]
>  user 'John' does not exist
>The user John does exist in the active directory.  I ran getent passwd
>to see if the user John was listed and indeed he was.  I then tried
>accessing the share again and it worked fine.  A little bit later, it
>stopped working again.  I found out that by running getent passwd,
>shares are accessaable for a short period of time but then the users
>are not found again by Samba until I run getent passwd again.
>Version Info:
>krb5: 1.2.7
>samba: 3.0.9
>        workgroup = 40SERVER1
>        realm = ascad.insideasc.com
>        password server = bethe.ascad.insideasc.com
>        server string =
>        security = ADS
>        encrypt passwords = yes
>        log file = /var/log/samba/%m.log
>        dns proxy = no
>        wins server =
>        idmap uid = 10000-20000
>        idmap gid = 10000-20000
>        winbind separator = #
>I appreciate any help.  Thank you.
I have the same problem. I have a Windows 2003 ADS as well.  I run 
getent passwd every minute from a cron job.  It works OK .

RHEL 4 ES  64bit
samba 3.0.10-1.4E
krb5 1.3.4-12


More information about the samba mailing list