[Samba] SOLVED smbpasswd doesn't work for users

Ulf Rasch u.rasch at seppelec.com
Thu Jun 16 15:02:46 GMT 2005

Dooooh! The new password was too short. Sorry for the noise.

Ulf Rasch wrote:
> Hello list,
> I have a problem with users changing their password from the command 
> line of the localhost with smbpasswd.
> As root the whole thing works fine but not as a normal user.
> First I had the connection to the localhost refused because I didn't 
> list localhost at the  interfaces and had "bind interfaces only" set to 
>  yes. (manual smb.conf) I fixed that and added localhost.
> Now I can connect to the localhost from the command line e.g. with 
> smbclient but smbpasswd still doesn't work as expected.
> user at host:~> smbpasswd
> Old SMB password:
> New SMB password:
> Retype new SMB password:
> machine rejected the (anonymous) password change: Error was : 
> Password restriction.
> Failed to change password for user
> Where do I have to configure the password restriction?
> I can post my smb.conf if that would be of any help.
> Any hint would be really helpful.
> Thanks
> Ulf

Ulf Rasch

Dpto. Automatización
Avda. Comunidad de Madrid,3 Portal 9.1º-A
28224 Pozuelo de Alarcón (Madrid)

Tel.: (+34) 91 799 0435
Fax: (+34) 91 351 4683
u.rasch at seppelec.com

More information about the samba mailing list