[Samba] smbpasswd -r connecting to old samba not working

Wayne Schroeder raz at positivenetworks.net
Tue Jun 14 23:07:18 GMT 2005

The error message is on the SERVER though... regardless of the server's
error bugs or not, the new smbpasswd won't work, yet the old one does...
so something in smbpasswd or it's supporting libs on the new version 3
source tree is doing something different I would imagine.

Jeremy Allison wrote:
> On Tue, Jun 14, 2005 at 05:39:01PM -0500, Wayne Schroeder wrote:
>>I am trying to build 3.0.14a and use it's smbpasswd binary to change
>>passwords on a remote debian woody samba install -- the samba install on
>>the remote debian machine is listed as '2.2.3a-15'  I can use the
>>previous smbpasswd binary from the same version on the client linux
>>machine to smbpasswd -r and change user passwords, but the new version
>>from 3.0.14a does not work against the 2.2.3a version.  I get an error
>>message like:
>>[2005/06/14 16:45:17, 0] smbd/chgpasswd.c:check_oem_password(817)
>>  check_oem_password: incorrect password length (-177685840).
>>I searched a bit and found that this has something to do with hash
>>lengths, or so it seems.  I tried various configuration changes in the
>>smb.conf that I was using to no avail -- I tried all the hash tuning and
>>lanman auth options I could find.
>>A few data points:
>>The binary in question from 3.0.14a DOES change passwords against an
>>exchange server just fine.
> It's a error message bug I'm afraid. Jerry just fixed it in the SVN source.
> If you bug him enough I'm sure he'll post a patch :-).
> Jeremy.

More information about the samba mailing list