[Samba] smbpasswd -r connecting to old samba not working

Wayne Schroeder raz at positivenetworks.net
Tue Jun 14 22:39:01 GMT 2005

I am trying to build 3.0.14a and use it's smbpasswd binary to change
passwords on a remote debian woody samba install -- the samba install on
the remote debian machine is listed as '2.2.3a-15'  I can use the
previous smbpasswd binary from the same version on the client linux
machine to smbpasswd -r and change user passwords, but the new version
from 3.0.14a does not work against the 2.2.3a version.  I get an error
message like:

[2005/06/14 16:45:17, 0] smbd/chgpasswd.c:check_oem_password(817)
  check_oem_password: incorrect password length (-177685840).

I searched a bit and found that this has something to do with hash
lengths, or so it seems.  I tried various configuration changes in the
smb.conf that I was using to no avail -- I tried all the hash tuning and
lanman auth options I could find.

A few data points:

The binary in question from 3.0.14a DOES change passwords against an
exchange server just fine.

The old 2.2.3a smbpasswd binary changes passwords against both the
exchange server and the remote linux running the same version of samba.

The 3.0.14a smbclient connects fine to the 2.2.3a samba linux host and
the exchange server.

It seems that the only thing that is broken is changing passwords on the
older remote samba server.  I am concerned that this may be a symptom of
a bigger issue of the new smbpasswd binary being incompatible with older
servers already deployed.

Thanks in advance for any help.

Wayne Schroeder

More information about the samba mailing list